The Planted Tank Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
just started my 30g x high. put in one bag of the fluval substrate and 60 lbs of eco complete. canister filter cascade 1000 with carbon, bio ceramic, and sponges. have a 2 bulb t5ho running on top.

the tank is cloudy and STINKS like rotten eggs or fertilizer. my wife is nagging me to death. is this normal?? will it pass soon?
 

Attachments

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
yes , the canister filter is running carbon. the smell was in the bags of the eco complete as well when i first added it.

i will try a water change now.


a cascade 1000 should provide enough flow for a 30 gal no?
 

·
Registered
Joined
·
11,721 Posts
You could do a couple of water changes including deep vacuuming the substrate, like rinsing it in the tank with a few partial fills and vacuuming it. Yes, this will destroy the 'scape, but it looks easy enough to set up again.
Then change the activated carbon daily or every couple of days. When there is a lot of stuff for it to remove it gets full pretty fast.
 

·
Registered
Joined
·
1,261 Posts
If your driftwood is rotting, it will stink up everything. Pull it out and smell....you'll know! Finding good wood for aquariums that doesn't rot up and stink can be an issue.
 

·
Registered
Joined
·
2,862 Posts
I haven't used any of those substrates so I couldn't say.

But it is known that some ornaments/decorations can give off a bad odor. I've had some myself that would cloud the water a bit and give off a foul smell. They were labeled for aquaria too. Might be worth pulling out real quick just to give it a smell check to confirm.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top