The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I've had this tank up and running for about 9 months now and I'm suddenly running into problems. When I started the tank I planted a bunch of jungle val in the background. It grew like a weed, quickly covering the background. I didn't really like the looks of it though and a few months ago decided to rescape. I bought stargrass, bacopa caroliniana, rotala indica, ammania senegalensis, an anubias and taiwan moss that I've made two moss walls out of. I also had a bronze crypt and vesuvias sword that were in the tank before. Within days the ammania, bacopa and rotala were all either completely dead or on their way. The leaves would melt and the base would turn black and just rot it's way up. There's only a handful of those still alive. I was planning to go high tech at the same time, but before I could everything was dead and I decided it wasn't worth it.
Shortly after I started experiencing a fairly severe potassium deficiency out of nowhere. My crypt which was doing so well has died back to about half it's size and loses a couple leaves a week. I dose liquid ferts weekly and add root tabs every month or so. I bought some seachem potassium and that has helped fix the problem, new leaves look fine on the crypt and anubias, though the crypt still has leaves dying. Meanwhile the moss is completely thriving and doing fantastic. I also found that my new plants are not rooting at all. I've had the vesuvias sword planted for 6 months or so, it hasn't grown at all and hasn't rooted at all. It sent a massive runner vertical once, but that's it. I've replanted the few surviving stems of the new plants I had but they haven't rooted at all either. Most of what's left has loosed itself and is now floating. They stay alive and even grow leaves slowly, but no roots whatsoever.
I'm really not sure what to do. Everything went from going great to terrible in an instant. I thought I fixed the potassium problem, but there has to be something else right? Really could use any help I can get, I haven't been able to find any useful information on this so far.
 

·
Registered
Joined
·
1,114 Posts
Just root tabs and liquid ferts. Dose an all purpose, little bit of iron, and now potassium.
I'm sorry. I missed that part! Anyway hows the husbandry looking like? How often do you change out the water? Are you dosing the same amount of ferts every time?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I'm sorry. I missed that part! Anyway hows the husbandry looking like? How often do you change out the water? Are you dosing the same amount of ferts every time?
I water change either every week or every other week, I play it by ear with the nitrates if I need to or not since it’s a shrimp tank. I dose about the same every time.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top