The Planted Tank Forum banner
algae bloom
1-18 of 18 Results
  1. Algae
    Hi guys! First post here so im gonna apologize for the long post. Just recently we upgraded our 55 gallon to a 150 gallon. We kept the cycle by moving gravel and didnā€™t add any new fish for a couple weeks. Water parameters have been consistently great since an initial ammonia spike. Wasn't...
  2. Algae
    Hello All, Can you please help me in identifying the type of algae that's forming across all my plants and decor. It's covering the leaves and stems of the plants too. I've attached pics for reference. I have a low tech tank and due to the Covid situation have not been able to get hold of any...
  3. General Planted Tank Discussion
    Hey everyone, I've been wanting to start a planted 75 gal and I keep having problems with green water. I did the whole thing, 15-25% water changes every other day, less feedings, gravel vac. my ammonia is still at 0.25 (has been for a while no matter what I do) and my nitrates are at 5ppm, my...
  4. General Planted Tank Discussion
    Howdy. New here. Please forgive if I am not posting properly. I have a 3 year plus 20 gallon live plant tank in my classroom. It has presented challenges over the years. Here is the recent battle that I am loosing big time: (Pict as attachment since I am unaware of how to place in line.) Stats...
  5. General Planted Tank Discussion
    Does anyone have experience with using Hydrogen Peroxide as a treatment for brown hair algae? I've seen some info for saltwater tanks, but not much for freshwater planted tanks. Currently have a low tech 7 gallon planted tank with anubias, java fern, monte carlo, pearl weed, rotala, and some...
  6. Algae
    New poster here but have been lurking and reading for quite some time! Thank you very much for including me into your community! Long story short I seem to have acquired an algae problem. I had been neglecting my aquarium and not dosing and not adding co2 for some time. Since then I have tried...
  7. Algae
    My tank was growing out pretty nicely, and I was doing water changes every week, EI dosing, etc. I then went for a trip out of town, came back, and my tank is overrun with brown algae (I presume). I've done a 50% water change, cleaned my canister filter, and cleaned my lilly pipes - and it...
  8. Algae
    Recently Ive set up my new tank and there has been an outbreak of algae. Though it has been fairly small, and I've managed to scrub it away with a toothbrush, I want to solve the root problem (which I suspect to be lighting). The specs for my tank are as follows: Tank: ADA 60-P 17 GAL...
  9. Algae
    I am setting up a 90G planted tank - my first serious tank - and am about a month into fishless cycling. I probably have another 2-3 weeks to go before the cycling completes, but I have been hit by an algae bloom that I am struggling to control and would love your advice on. I have a several...
  10. Algae
    hi guys, My aquarium was algae free. But since yesterday there has been algae bloom. I searched online but could not find which algae is this. My tank is 30 days old. EI dosing. 8 hours of High light. 2BPS CO2. Hard Water. Please suggest me what has to be done. :crying::crying...
  11. General Planted Tank Discussion
    I have a relatively large piece of driftwood that has been in my tank for 4 years or so. I noticed particularly during the last few months that it has black algae spore like things all over it, and is pretty much completely covered in various type of algae. This got especially worse after I...
  12. Low Tech Forum
    Hi Guys, I have recently set up a 10 planted tank and am having algae bloom every few days. Let me summarize the status of my tank: 1. Tank is 1.5 months old. 2. I have planted Alternanthera Reineckii, Rotala rotundifolia Indica, Anubias and micranthemum umbrosum (Montecarlo). 3. Among these...
  13. Planted Nano Tanks
    It's an established tank, about 2 years old. DIY Yeast co2 w/ bubble ladder, planted+ lighting, all tests are great but... I STILL CAN'T GET RID OF THIS RIDICULOUS ALGAE BLOOM. It has been almost a 3 month war. The algae appears on all plants and glass about six inches above the substrate...
  14. Algae
    Hey Everyone, Both my 55G and 29G planted tanks (but particularly my 29G right now) have this dark green, stringy growth on my plants, rocks, and filter. It's even attached to the walls of the tank itself. See the attached picture, which shows it. First, does anyone know what this is...
  15. Algae
    Any advice on why this algae is appearing in my tank? I did a 10 % water change yesterday and a 50% on saturday. I dose the seachem line and follow their protocol from their website. I dose Co2 ( I speculate it is due to low CO2 levels, but idk ) I feed my fish every other day to avoid...
  16. Low Tech Forum
    I have read a lot about the possible causes and treatments dealing with green spot algae. However, there has not been a clear cut solution/method to eradicate it, especially from plants. I am looking for someone that has had proven success dealing with GSA and what method they used to do so...
  17. Plants
    Hello, I'm about a month into my first planted tank and I've been having a problem with some green water. I doubt the cause is lack of filtration because I'm running two 20-30 gal HOB filters (no carbon of course) and it's a 20 gal tank. It's heavily planted and there's quite a bit of algae. I...
  18. General Planted Tank Discussion
    I am a beginner aquatic horticulturist an (algae grower according to The Planted Tank and my personal tank.) I had a tank with 3 plants a plug of Dwarf Hair Grass a Micro China Sword and Baby-tears. I got a little carried away and got all of these before i got enough light or CO2 in the tank and...
1-18 of 18 Results
Top