Redsea Turbo CO2 Bio System..is it working? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-17-2005, 08:50 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Dec 2005
Posts: 5
Redsea Turbo CO2 Bio System..is it working?

Ok...

So I bought a new handydandy Redsea Turbo CO2 Bio System. I set everything up just like it says in the instructions.

I mixed the sugar, yeast and water and mixed it for 2min.

Its a typical DIY system, where you have a reactor chamber, a tube going from the chamber to a powerhead.

My only question is...
Should I be seeing little CO2 bubbles coming from the exit valve of the powerhead? How do I know if the reactor chamber is actually creating CO2?

Ok, thats more than one question.

But I'm just curious as to if this thing is actually working. Its been going for atleast 3-4 hours and I don't see any bubbles coming from the exit valve of the powerhead.

I opened up the reactor chamber to see if its fizzing like a bottle of coke...but its just kinda sitting there and smelling like dough for bread.

Any thoughts/hints?

Thanks,

-rob C
pnKroK is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-18-2005, 07:26 AM
Planted Tank Enthusiast
 
jimmydrsv's Avatar
 
PTrader: (4/100%)
Join Date: Apr 2005
Location: Los Gatos, CA
Posts: 710
I would leave it closed and wait 24 hours before i was worried.
jimmydrsv is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome