Magnum polishing filter gassing - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-28-2020, 12:43 AM Thread Starter
Planted Tank Obsessed
 
butchblack's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2019
Location: Waltham, Massachusetts, USA
Posts: 371
Magnum polishing filter gassing

I seem to be having a problem with my Magnum polishing filter outgassing. The first time it happened I thought it was that I didn't have the top on correctly or I didn't fill the canister before putting it back together. It's still doing it. The filter is safely underwater, so it's not an air leak. It's to the point that there are a plethora of tiny bubbles floating in the tank. Any ideas what could be causing it and is it harmful to the tank or water chemistry?

The real fountain of youth is being a musician
butchblack is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-28-2020, 12:17 PM
Planted Tank Obsessed
 
EdWiser's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2015
Location: Louisville,Kentucky
Posts: 453
You need to make sure the rubber gasket is installed on the bottom of the filter.
EdWiser is offline  
post #3 of 4 (permalink) Old 07-28-2020, 08:14 PM Thread Starter
Planted Tank Obsessed
 
butchblack's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2019
Location: Waltham, Massachusetts, USA
Posts: 371
Quote:
Originally Posted by EdWiser View Post
You need to make sure the rubber gasket is installed on the bottom of the filter.
It was installed. I'll have to check to see if it is seated correctly. Is it possible that one of the cartridges is bad causing poor sealing?

Quote:
Originally Posted by EdWiser View Post
You need to make sure the rubber gasket is installed on the bottom of the filter.
I cleaned mine out today, and this time, instead of putting the gasket in the bottom of the housing, I put it on the bottom of the filter, then put it into the filter housing. It outgassed for about 15 minutes and stopped, so hopefully, I solved the problem. The next test will be the next time I put one in of their pleated canister filters instead of the sponge sleeve.

The real fountain of youth is being a musician

Last edited by Darkblade48; 08-01-2020 at 12:53 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
butchblack is offline  
 
post #4 of 4 (permalink) Old 07-30-2020, 01:37 PM
Planted Tank Obsessed
 
EdWiser's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2015
Location: Louisville,Kentucky
Posts: 453
The rubber gasket is the issue. If it doesn’t seal the filter correctly it becomes an issue. I use this filter with diatomaceous earth.
EdWiser is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome