Aquario Neo Co2 Diffuser - The Planted Tank Forum
 2Likes
  • 1 Post By Jeffww
  • 1 Post By gus6464
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 06-17-2020, 02:42 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Aquario Neo Co2 Diffuser

Does anyone have issues with this diffuser. The design has a long acrylic stem that seems to get filled with water when co2 is off and restarting has been very inconsistent for me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 06-17-2020, 06:11 PM
Wannabe Guru
 
hbosman's Avatar
 
PTrader: (2/100%)
Join Date: Oct 2006
Location: Leesburg Virginia
Posts: 1,734
I use them and yes they fill up with water over night when they are turned off. My CO2 pressure is 20 PSI so, it pushes the water out when it starts up. So, it hasn't been a problem for me.
hbosman is offline  
post #3 of 15 (permalink) Old 06-17-2020, 06:30 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Thanks for that info. I'm running around 35psi and sometimes it will push the water through but it can take hours, other times nothing and i need to separate it from the tubing and turn it over. This never happened with the old-fashioned glass ones. I even have a check valve on the tubing going down the outer side of the glass.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
 
post #4 of 15 (permalink) Old 06-17-2020, 08:44 PM
Planted Tank Guru
 
Jeffww's Avatar
 
PTrader: (11/100%)
Join Date: Aug 2010
Location: Albany, CA
Posts: 2,508
You may have a leak and are operating at a lower pressure than you think. I have 2 small ones and one large sized one and they all fill with water but the gas comes out after 5-10 minutes after solenoid opening.
hbosman likes this.

Fluval Spec V
7x Microsynodontis sp (1)

10g Terrarium
1x Cranwelli Horned Frog
Jeffww is offline  
post #5 of 15 (permalink) Old 06-17-2020, 09:17 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Does make sense that it would be a pressure thing, but when I put a regular ceramic diffuser on it there isn't a problem and @hbsoman stated his is working with 20 psi. I'll try it on my other setup and see if the problem repeats - thanks


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
post #6 of 15 (permalink) Old 06-20-2020, 10:38 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Should have waited on got the new one.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
post #7 of 15 (permalink) Old 06-21-2020, 04:58 AM
Planted Tank Guru
 
PTrader: (7/100%)
Join Date: Dec 2011
Location: San Diego, CA
Posts: 2,519
I just got the new one and it's really good. Pushing 25 psi through it no problem. The S size is absolutely tiny and bubbles are way smaller than my ada one.

Sent from my ONEPLUS A6013 using Tapatalk
gus6464 is offline  
post #8 of 15 (permalink) Old 06-21-2020, 01:28 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Quote:
Originally Posted by gus6464 View Post
I just got the new one and it's really good. Pushing 25 psi through it no problem. The S size is absolutely tiny and bubbles are way smaller than my ada one.

Sent from my ONEPLUS A6013 using Tapatalk
Does it start right up for you? This (older one) is the only diffuser I have that takes 2 hrs to start up. I tested it on one that is running an atomizer that requires at least 30 psi and it still took forever to start.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
post #9 of 15 (permalink) Old 06-21-2020, 03:44 PM
Planted Member
 
PTrader: (0/0%)
Join Date: Aug 2018
Posts: 283
I had the medium and it would start up in under a minute after the solenoid came on.

My Tank Journal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AcidGambit is offline  
post #10 of 15 (permalink) Old 06-21-2020, 05:46 PM
Planted Tank Guru
 
PTrader: (7/100%)
Join Date: Dec 2011
Location: San Diego, CA
Posts: 2,519
Quote:
Originally Posted by Asteroid View Post
Does it start right up for you? This (older one) is the only diffuser I have that takes 2 hrs to start up. I tested it on one that is running an atomizer that requires at least 30 psi and it still took forever to start.
Yeah takes maybe 30 seconds for the co2 to get to it and start flowing. Did you soak it in water for 30 minutes before using it the first time?

I would put it in bleach for 5 mins while running some co2 through it to see if its clogged as that's what the manual says to do if you are getting almost no flow which you are.

Ed. forgot use a 50/50 bleach water solution for the dip.
Asteroid likes this.

Last edited by gus6464; 06-21-2020 at 05:57 PM. Reason: add
gus6464 is offline  
post #11 of 15 (permalink) Old 06-21-2020, 06:46 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Quote:
Originally Posted by gus6464 View Post
Yeah takes maybe 30 seconds for the co2 to get to it and start flowing. Did you soak it in water for 30 minutes before using it the first time?

I would put it in bleach for 5 mins while running some co2 through it to see if its clogged as that's what the manual says to do if you are getting almost no flow which you are.

Ed. forgot use a 50/50 bleach water solution for the dip.
It works, it's just that it takes forever to start up, which of course sounds like pressure, but when I use any other diffuser/atomizer on the same line it starts up within a few minutes. Perplexed - Twilight Zone.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
post #12 of 15 (permalink) Old 06-24-2020, 06:00 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2020
Posts: 24
I just switched to this from a jardli glass which took 30min to start. Neo takes around 1 minute, even though I failed at bending it properly.
Kandomere is offline  
post #13 of 15 (permalink) Old 06-24-2020, 06:17 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Quote:
Originally Posted by Kandomere View Post
I just switched to this from a jardli glass which took 30min to start. Neo takes around 1 minute, even though I failed at bending it properly.
I guess i got a lemon. Even the suction cups are terrible. I can't make it through a day without them coming off the glass.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
post #14 of 15 (permalink) Old 06-24-2020, 06:37 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2020
Posts: 24
I soaked mime overnight. That might have helped.
Kandomere is offline  
post #15 of 15 (permalink) Old 06-24-2020, 09:35 PM Thread Starter
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 2,120
Quote:
Originally Posted by Kandomere View Post
I soaked mime overnight. That might have helped.
I've decided to return the diffuser. If I get another one I will follow-up here what happenend.
the crappy suction cups were the last straw.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome