Eheim professional 3 - The Planted Tank Forum
 1Likes
  • 1 Post By PlantedRich
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-02-2020, 06:25 PM Thread Starter
Planted Member
 
PTrader: (1/100%)
Join Date: Jan 2020
Location: Shoreline, WA
Posts: 176
Eheim professional 3

I got this canister filter along with a 55g tank for 60$ so I couldn't really pass it up.

It works fine but my problem is the impeller rattles a bit, I'm guessing I just need a new impeller but for 25$ I think I can live with it.

Anyone know any easy fixes? I had to take out the on/off valve cuz it was broke

At least I can grow Algae
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Crazyjayb is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-03-2020, 01:20 AM
Planted Tank Enthusiast
 
Leeatl's Avatar
 
PTrader: (1/100%)
Join Date: Aug 2015
Location: Woodstock,Georgia
Posts: 924
Get some pure silicone lube and put a dab on impeller shaft . After a little funk gathers/grows on the shaft and in the impeller well it should quiet down . I get pure silicone from a local dive shop .

My wife says if I get one more aquarium she is going to leave me . I sure am going to miss her fried chicken .
Leeatl is offline  
post #3 of 5 (permalink) Old 02-04-2020, 01:25 AM Thread Starter
Planted Member
 
PTrader: (1/100%)
Join Date: Jan 2020
Location: Shoreline, WA
Posts: 176
Will try that 🙂

At least I can grow Algae
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Crazyjayb is offline  
 
post #4 of 5 (permalink) Old 02-04-2020, 04:26 PM
Planted Tank Guru
 
PlantedRich's Avatar
 
PTrader: (2/100%)
Join Date: Jul 2010
Location: United States
Posts: 12,121
Also an easy fix for lubing things is the normal, no scent, no flavor petroleum jelly. Mention of petroleum always sets off alarm bells but keep in mind that it is just a name and is no longer petroleum. Same can be said for plastic which was also petroleum at one time. If the impeller and shaft are worn, the fix may/may not last long term, though.
deeda likes this.
PlantedRich is offline  
post #5 of 5 (permalink) Old 02-04-2020, 04:53 PM Thread Starter
Planted Member
 
PTrader: (1/100%)
Join Date: Jan 2020
Location: Shoreline, WA
Posts: 176
Quote:
Originally Posted by PlantedRich View Post
Also an easy fix for lubing things is the normal, no scent, no flavor petroleum jelly. Mention of petroleum always sets off alarm bells but keep in mind that it is just a name and is no longer petroleum. Same can be said for plastic which was also petroleum at one time. If the impeller and shaft are worn, the fix may/may not last long term, though.
Oops, meant petroleum jelly not silicone. It seems to have helped a bit but it is still clacking around. Probably need a new impeller 😞 20-30$ not including shipping to get one though

At least I can grow Algae
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Crazyjayb is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome