Issue with Co2 paintball tank install - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-28-2019, 10:42 PM Thread Starter
Algae Grower
 
Broutilde's Avatar
 
PTrader: (0/0%)
Join Date: Nov 2018
Posts: 56
Issue with Co2 paintball tank install

Hello everyone,
I just received my mini regulator (Aqualabs) and started installing it on my paintball tank. I'm running into an issue that I can't seem to resolve.
So I basically followed the UNS install that I found here : https://youtu.be/8sFMFyOvhUk and did everything exactly the same. However when I screwed in the regulator with the paintball adapter to the tank, nothing happened. I tried to tighten it up and then it started hissing and co2 was evaporating loudly between the paintball adapter and the regulator. If I unscrew it a bit less I end up having a bit of pressure without any hissing sound but can't go any higher than 0.2. Any advice?
Thank you
Attached Thumbnails
Click image for larger version

Name:	15590832331701160295988090433595_1559083237596.jpg
Views:	4
Size:	155.9 KB
ID:	882143  

Click image for larger version

Name:	15590832920062372857019174022988_1559083298941.jpg
Views:	4
Size:	106.7 KB
ID:	882145  

Click image for larger version

Name:	15590833118334581530383305817290_1559083319036.jpg
Views:	4
Size:	115.7 KB
ID:	882147  

Broutilde is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-03-2019, 02:40 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2018
Posts: 9
Maybe you're o ring is bad? I had the same trouble with the two canisters I use. Each time I unscrewed my regulator, the threads would put a small nick in the o ring, causing it to leak. I bought a package of universal o rings from amazon. Problem solved for me.
jennation is offline  
post #3 of 3 (permalink) Old 06-03-2019, 06:33 PM Thread Starter
Algae Grower
 
Broutilde's Avatar
 
PTrader: (0/0%)
Join Date: Nov 2018
Posts: 56
I figured it out, it was the paintball adapter that was faulty. Thank you though!
Broutilde is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome