Bloody Mary Baby Shrimp? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-09-2020, 09:15 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2020
Posts: 11
For 2 weeks, I didn't see any shrimp berried. I only saw their saddle.

Then, I saw a baby shrimp, it has no color. I can only saw 1 despite I looked at the tank for hours lol.

Then, it is gone for 2 days already. I can't find it anymore in the tank.


Is that really a baby shrimp from Bloody Mary? I saw on the internet, the baby has a yellow orange color. But the one in my tank had no color. Please see the attached pictures.

Also, is it really that my shrimp could give birth to only 1 shrimp?
Attached Thumbnails
Click image for larger version

Name:	20200509_170554_1589058844443.jpg
Views:	15
Size:	223.0 KB
ID:	897987  

Click image for larger version

Name:	20200509_170803_1589058858860.jpg
Views:	14
Size:	213.2 KB
ID:	897989  

Shonick2 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-09-2020, 10:47 PM
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Mar 2019
Location: PNW
Posts: 970
Its a baby shrimp for sure......if that helps. Looks like my baby neos. What it grows up to be is anyone's guess till it gets larger and colors up.

Oh and good luck finding and tracking all of them. Super tiny as u can see.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Darkblade48; 05-13-2020 at 08:25 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
Quint is offline  
post #3 of 3 (permalink) Old 05-10-2020, 07:07 PM
Planted Tank Guru
 
Zoidburg's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2016
Location: Nevada
Posts: 2,977
Yes, it's possible for a female to carry only a few eggs. Some years ago, I ordered a group of YKK's. After a week or so, I had two extra shrimp that I don't recall having when I acclimated them into the tank... and that was on top of 2 extra I found that I wasn't supposed to have! I don't recall the exact amount that was shipped, but it was something like 15 shipped, 17 arrived, then I had 19.

If the parameters aren't right or there's not enough biofilm, the offspring could parish... or they just might be hiding.


And neos are born "colorless". (might not be colorless under a microscope though!)
Zoidburg is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome