Introduced plants into planted aquarium and one shrimp died. - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-22-2020, 08:19 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: Mar 2020
Posts: 1
Introduced plants into planted aquarium and one shrimp died.

I am extremely new to this community as I have never had a planted tank before. I have had my tank about a month now, I had two ghost shrimp and a mystery snail in my ten gallon freshwater tank.

I introduced two plants but one said “snail free” on it. I think that means I must’ve unintentionally introduced a pesticide into my aquarium and thats what killed one of my ghost shrimp (kyle).

I also notice I have two visible hitch hikers (two bladder snails) and also some white bugs I believe to be centepods.

I dont want my tank to have pesticides in it as I plan on having more shrimp in the future.

How can I make my tank safe again?
Should I remove my bladder snails?

Thanks and sorry Kyle for my ignorance):
c0594438 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-22-2020, 10:44 PM
Planted Tank Guru
 
Zoidburg's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2016
Location: Nevada
Posts: 3,175
Bladder snails are harmless - just unsightly

Many plants could be treated with copper to get rid of snails... which means they are invert dangerous. It's also possible another chemical was used.

Best to remove plants and carefully source new plants in the future.
Zoidburg is online now  
post #3 of 3 (permalink) Old 03-23-2020, 09:26 PM
Planted Tank Enthusiast
 
Bandit1200's Avatar
 
PTrader: (4/100%)
Join Date: Dec 2010
Location: Houston, Texas
Posts: 851
I think it's unlikely that you introduced something very toxic by adding the plants. You said that it introduced snails and likely copepods or possibly scuds. If there was something toxic, it would have killed everything, not just one shrimp. Sometimes shrimp die. It doesn't always indicate a problem.
Bandit1200 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome