Safeguard vs Freshwater Velvet - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-17-2015, 09:50 PM Thread Starter
Planted Tank Obsessed
 
WickedOdie's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2015
Location: Canada
Posts: 454
Alright, so my shipment of safeguard has come in, it has come in 3, 4 gram packages.

I'll be using 0.1 gram per 10 gallons of water. I'll be using this on my first first in my hospital tank before I use it on my display tank with inverts to make sure it absolutely works.

I'll be dosing 0.1g once weekly for 4 weeks. Doing a 50% or more water change before doing so. I'll also have the temperature at 82 degrees to speed up the life cycle of the velvet, and I'll be keeping them completely blacked out except for the few minutes of feeding.

As there is very little information on the internet about freshwater velvet and treating it, I'll be using this as a way of documentation and to help the community with this terrible terrible parasite.

I'm actually going to change my regimen up. My nitrates are rising faster than I'd like, so I'm going to do a 50%-80% water change every 4 days and re-dose. I'll be doing my water change tomorrow morning.

So far there are no ill effects towards the fish.

So I did my first water change yesterday, about 70%. I added another .3 grams of fenbendazole to the 29 gallon tub I have them in. The fish show no negative signs to the fenbendazole. I have not noticed any regression in the velvet, however it may take time to kill. I'll continue with treatment and keep you updated.

Last edited by Darkblade48; 12-27-2015 at 07:18 AM. Reason: Please use the edit function for back to back posts
WickedOdie is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-22-2015, 09:43 PM
Children Boogie
 
mistergreen's Avatar
 
PTrader: (13/100%)
Join Date: Dec 2006
Location: Cincinnati
Posts: 16,743
jezzz, you're still dealing with velvet all this time?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mistergreen is offline  
post #3 of 4 (permalink) Old 11-22-2015, 10:38 PM Thread Starter
Planted Tank Obsessed
 
WickedOdie's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2015
Location: Canada
Posts: 454
Quote:
Originally Posted by mistergreen View Post
jezzz, you're still dealing with velvet all this time?
Yep, lol.
WickedOdie is offline  
 
post #4 of 4 (permalink) Old 12-24-2015, 01:49 PM
Planted Member
 
Dropline's Avatar
 
PTrader: (2/100%)
Join Date: Dec 2014
Location: MI
Posts: 274
Quote:
Originally Posted by WickedOdie View Post
I'll be dosing 0.1g once weekly for 4 weeks. Doing a 50% or more water change before doing so. I'll also have the temperature at 82 degrees to speed up the life cycle of the velvet, and I'll be keeping them completely blacked out except for the few minutes of feeding.
I do not have Velvet, but did read on your other thread about it. Did this take care of things? No update and it has been 5 weeks since you started this 4 week process so just wondered. Even if I do not have something I like to see how people fix things and the results in case I ever do.

I hope this worked for you...
And Merry Christmas Eve!!

Main Tank


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dropline is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome