Help...Brown Algae Issues - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-21-2015, 12:30 AM Thread Starter
Planted Member
 
Nazasaki's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2015
Location: Pennsylvania
Posts: 175
Help...Brown Algae Issues

Alright so it's been about two months since I had my low tech 10 gallon up and running. I'm having a bit of an algae problem. I have brown algae (diatoms). It isn't totally covering the tank but it's making my Anubis and Water Wisteria look unsightly. It wipes away easily with my finger. I've heard this is normal during the cycling process but when will it go away? Anything I can do? My snails won't clean off the plants. Below I listed my tanks inhabitants as well as other general info:

Ammonia 0
Ph 7.6
Nitrate 0
Nitrite 0

Inhabitants:
1 king betta
4 nerite snails

Plants:
5 Anubias nana attached to driftwood and rocks
Water wisteria
9 marimo balls

Substrate:
Basic gravel

Ferts:
Seachem fert tabs
Seachem flourish added once a week
Api strss zyme and stress coat added each water change
Prime water conditioner added to each water change

2 - 10 watt compact flourescent bulbs
Lights are on from 8 Am to 6 PM
20 gallon filter
Heated to 76 degrees F

20% water change each week. I don't vacuum my gravel or wipe glass (snails keep glass spotless).


Also, will this algae kill my plants? Should I get an oto cat? Thanks!

"Until one has loved an animal a part of one's soul remains unawakened" ~ Anatole France
Nazasaki is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome