Crinum detached from roots - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-20-2014, 04:53 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2014
Location: Georgia
Posts: 94
Crinum detached from roots

I'm struggling with my first crinum plant. At first, the leaves were turning black, but I noticed that some of the rhizome was under the substrate, so I made sure that only the roots were under and the leaves started looking good and growing well again. But now the crinum is detached from the roots. I don't know why. It's just floating on the surface right now. The part that the roots were growing out of is brown and looks fuzzy in the water, but I do have a brown algae problem right now. What should I do? I know with lots of plants, if you just leave the plant floating for a while, roots will start to grow and then you can plant again. Is it the same with crinum? The leaves are still green and a couple of the tiny ones look like new shoots. I snapped a few shots of the root area of the plant. I apologize if they're useless lol.



NiaCas is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-20-2014, 05:54 PM
Planted Tank Guru
 
HybridHerp's Avatar
 
PTrader: (12/100%)
Join Date: May 2012
Location: New York
Posts: 3,890
if that brown part is squishy rub/take it off....seems like it rotted

My 75 gallon High Tech Tank:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My 10 gallon High Tech Tank:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My 5.5 gallon nano College Dorm Tank:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mom's Spec V:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HybridHerp is offline  
post #3 of 3 (permalink) Old 11-20-2014, 11:19 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2014
Location: Georgia
Posts: 94
Yeah, it was kinda squishy, so I took it off. Thanks! Will it be ok now? Should I just let it float? Do I need to move it to its own container for a while?
NiaCas is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome