Anyone else have trouble with this diffuser? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-07-2008, 02:25 PM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Aug 2008
Posts: 36
Anyone else have trouble with this diffuser?

I've been using a Dr. Foster-Smith glass c02 diffuser on my DIY c02. It worked really great at first, producing wicked tiny bubbles. But now the built in glass check valve seems to be stuck. It won't budge at all, so now no c02 can be diffused, it was just building up in the line.

Has anyone else had this problem? Anyway to fix it? I'm about ready to chuck it and get a different one.
xcvtys is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-07-2008, 03:32 PM
Planted Tank Guru
 
PTrader: (266/100%)
Join Date: Sep 2006
Location: Northern California
Posts: 9,417
Why is it stuck? Did some of the yeast mixture get stuck in there?

You can try flushing it with some water to see if it'll open up again. It'll have to be dried before it'll work reliably again though.
epicfish is offline  
post #3 of 3 (permalink) Old 10-07-2008, 04:19 PM
Planted Tank Enthusiast
 
alan j t's Avatar
 
PTrader: (41/100%)
Join Date: Feb 2008
Location: RENO NV
Posts: 767
i read somewhere to soak it in some dilutade bleach for a while
when it gets stuck or clogged
alan j t is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome