Medication mistake - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-19-2014, 08:07 PM Thread Starter
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Jan 2014
Location: London, England
Posts: 312
Medication mistake

Okay so I just had to euthanise one of my neon tetra as he was covered in white spots and I thought the best option for it was that, I own melafix and primafix and I stupidly dosed the tank with the bacterial one instead of fungal, my question is would it be a bad idea to dose the fungal one too? I'm presuming they will O.D if I do that, any suggestions? Also should I stop dosing ferts whilst I'm treating the tank, And will it cause any of my dhg to melt? Thanks.

Bump: These just incase nobody knows! Obviously ignore the marine one
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-10-19-21-09-03-1.jpg
Views:	36
Size:	30.8 KB
ID:	381162  

AshNeon93 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-19-2014, 10:29 PM
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Nov 2012
Location: Central Texas
Posts: 3,446
Raised white specks like salt? Ich. Even a fish totally covered can recover just fine.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My current project, a 65 gallon aquarium stocked with vernal pool fauna.
Betta132 is offline  
post #3 of 5 (permalink) Old 10-19-2014, 10:34 PM Thread Starter
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Jan 2014
Location: London, England
Posts: 312
Quote:
Originally Posted by Betta132 View Post
Raised white specks like salt? Ich. Even a fish totally covered can recover just fine.
Yeah I know it was ich, but I don't have a quarantine or heaters etc to set up, so I got him out the tank the only way I could before it multiplies even more, the plan was to treat the tank, but I put the wrong meds in.
Which brings me back to my question, can I put the fungal meds in at the same time as bacterial?
AshNeon93 is offline  
 
post #4 of 5 (permalink) Old 10-19-2014, 10:45 PM
Planted Member
 
doggo's Avatar
 
PTrader: (6/100%)
Join Date: Jun 2014
Location: Midland TX
Posts: 174
Ich is not a fungus. There's a current thread that discusses this -
https://www.plantedtank.net/forums/sh...d.php?t=744081
doggo is offline  
post #5 of 5 (permalink) Old 10-19-2014, 11:44 PM
Planted Tank Guru
 
PlantedRich's Avatar
 
PTrader: (2/100%)
Join Date: Jul 2010
Location: United States
Posts: 12,121
Pima and Mela can be used together and are my choice as I hardly ever have a specific disease that I can say for sure. They are safe for the bacteria and cheap, so I use both. BUT---They do nothing for ich!
PlantedRich is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome