55 gallon tank smells fishy - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 05-07-2014, 01:25 AM Thread Starter
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Feb 2014
Location: texas
Posts: 927
55 gallon tank smells fishy

My 55 gallon tank started smelling pretty fishy yesterday , so I tested all the parameters. They were all good. This is a 4 month old planted tank. I am dosing excell , iron and potassium as directed. I did a 40% WC today. Any ideas why it started smelling bad.

Last edited by rick dale; 01-11-2015 at 06:47 PM.
rick dale is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 05-07-2014, 03:45 AM
Planted Tank Obsessed
 
Mizuhuman's Avatar
 
PTrader: (6/100%)
Join Date: Mar 2013
Location: Philadelphia, PA
Posts: 426
What do you mean by its smells "fishy"? Try and give us a better description.
Does it smell like rotten eggs or something? If yes, then you have a problem.
Do you have any fish in the tank because I don't see any from the picture.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mizuhuman is offline  
post #3 of 14 (permalink) Old 05-07-2014, 04:15 AM
Fresh Fish Freak
 
lauraleellbp's Avatar
 
PTrader: (70/100%)
Join Date: Feb 2008
Location: Tampa, Florida
Posts: 24,403
What kind of water conditioner do you use?

I use Prime, and I think it stinks LOL





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Next meeting Monday, Oct 13, 2014 @ 7:15pm- See ya there!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lauraleellbp is offline  
 
post #4 of 14 (permalink) Old 05-07-2014, 04:34 AM
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Oct 2013
Location: Ca.
Posts: 625
My tank never smelled but when I tore it down the substrate had a horrible smell to it .

125g,75g,50g,40g,27g,10g
Aqguy is offline  
post #5 of 14 (permalink) Old 05-07-2014, 07:30 AM Thread Starter
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Feb 2014
Location: texas
Posts: 927
I use prime water conditioner. I have 5 tetras 2 zebra donias , 2 guppies , 2 Cory cats and 2 otocinclius.
rick dale is offline  
post #6 of 14 (permalink) Old 05-07-2014, 07:35 AM Thread Starter
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Feb 2014
Location: texas
Posts: 927
It doesn't smell like rotten eggs. Just kinda of a musty fish smell. Kinda hard to explain. Haven't been cleaning my substrate very well . its Eco complete and it gets sucked up the siphon hose if I get anywhere near it.
rick dale is offline  
post #7 of 14 (permalink) Old 05-07-2014, 07:50 AM
Planted Member
 
Chiefston's Avatar
 
PTrader: (4/100%)
Join Date: Dec 2011
Location: Tempe, AZ
Posts: 153
I can normally smell cyanobacteria (BGA) when it starts growing in my tanks. It has a distinctive "fish tank" smell to it. Maybe thats what you're smelling?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Chiefston is offline  
post #8 of 14 (permalink) Old 05-07-2014, 08:00 AM Thread Starter
Planted Tank Enthusiast
 
PTrader: (0/0%)
Join Date: Feb 2014
Location: texas
Posts: 927
What can be done about the cyanobacteria , and how do I know if I have it?
rick dale is offline  
post #9 of 14 (permalink) Old 05-07-2014, 01:54 PM
Planted Tank Guru
 
roadmaster's Avatar
 
PTrader: (1/100%)
Join Date: Nov 2009
Location: Missouri united states
Posts: 5,576
Dirty filter's are contributer,lack of regular weekly water changes is another.
With that said,all my tank's smell like wet dirt and give me no cause for concern for I perform weekly 50% water changes and clean filter's once a month.Prolly got three inches of dirt in my tank's covered with blasting media that never get vaccumed.
I'll bite on previous post.."What does Cynobacteria smell like?"
My tank's have distinct fishy smell cause they're full of fish but no Cynobacteria.
roadmaster is offline  
post #10 of 14 (permalink) Old 05-07-2014, 02:11 PM
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Feb 2014
Location: Suriname
Posts: 492
I think you said that you disturbed your substrate and that is when you noticed the smell. A lot of bacteria end up living and doing their job in the substrate and things end up rotting there. It is pretty normal to get a strong smell from mature substrate when you disturb it.
Steve002 is offline  
post #11 of 14 (permalink) Old 05-07-2014, 02:22 PM
Planted Member
 
MamaJu's Avatar
 
PTrader: (7/100%)
Join Date: Jun 2013
Location: Apharetta, Ga
Posts: 211
The iron can smell like blood.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MamaJu is offline  
post #12 of 14 (permalink) Old 05-07-2014, 06:50 PM
Algae Grower
 
abe86's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2014
Location: Los Angeles
Posts: 49
Quote:
Originally Posted by MamaJu View Post
The iron can smell like blood.

Actually It's blood that smells like iron. Not the other way around. Lol.


Sent from my iPhone using Tapatalk
abe86 is offline  
post #13 of 14 (permalink) Old 05-07-2014, 06:52 PM
Algae Grower
 
abe86's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2014
Location: Los Angeles
Posts: 49
Quote:
Originally Posted by rick dale View Post
My 55 gallon tank started smelling pretty fishy yesterday , so I tested all the parameters. They were all good. This is a 4 month old planted tank. I am dosing excell , iron and potassium as directed. I did a 40% WC today. Any ideas why it started smelling bad.

You probably disturbed the substrate. That usually happens to me. But it'll go away pretty soon. So good luck.


Sent from my iPhone using Tapatalk
abe86 is offline  
post #14 of 14 (permalink) Old 05-07-2014, 07:11 PM
Children Boogie
 
mistergreen's Avatar
 
PTrader: (13/100%)
Join Date: Dec 2006
Location: Cincinnati
Posts: 16,743
My tank did that a few weeks ago. The smell went away after a water change.
mistergreen is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome