New Tank setup - Please help - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-04-2014, 04:51 PM
key5000
Guest
 
Posts: n/a
Unhappy New Tank setup - Please help

Hello Everyone,

This is my first post to this forum and I'm hopping that I can find some help from here for my new tank setup.

I had a 55 gallon tank that my wife want to plant a plants in it along with some fish. I have been trying on this for 2 years and it failed. All the plants is dying after couple months and if they alive, they does not look green or does not look nice. I did try to replace the gravel with CaribSea Eco-Complete substrate; liquid feterlize and even adding a CO2 tank but the result is always the same: plants die or does not looks nice/green. https://www.plantedtank.net/forums/im...cons/icon9.gif

Last week, I break down the tank: trash everything: plants, substrate...

Would anyone please help me on building up again and keeping it green and looks nice as yours tank.


Thanks
KEY
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome