RO question - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-25-2014, 11:53 PM Thread Starter
Planted Tank Obsessed
 
Racedoc's Avatar
 
PTrader: (0/0%)
Join Date: Nov 2013
Location: Eastern US
Posts: 301
RO question

Hi all, more questions lol. I have a 90 FW planted tank, during Seachem flourish comprehensive, phosphate, and nitrogen twice a week. Leaf zone weekly. Excel daily. Pressurized CO2. My question is I use all RO water for the tank (got a 30 gal RO system for the house). The water also has passed through a whole house carbon filter and water softener. I just read about Seachem equilibrium and ordered some up. Should I be using this in addition to the ferts I'm using now? I've had some angel losses over past 6 months I couldn't explain and starting to wonder if it's the RO water. Thanks!
Racedoc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-26-2014, 12:06 AM
Wannabe Guru
 
PTrader: (18/100%)
Join Date: Dec 2009
Location: Standish, MI.
Posts: 1,827
I use straight RO and sometimes DI water in my tanks. So I doubt it's the water.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jmowbray is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome