Mystery Algae?? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-15-2013, 10:56 PM Thread Starter
Algae Grower
 
PTrader: (4/100%)
Join Date: Nov 2013
Location: Colorado
Posts: 94
Mystery Algae??

Over the last year I have been battling this mystery algae/funk and I continuously remove it to watch it come back again. I simply wish to determine what is causing the problem. In the past I had a Marineland DB and have recently switched to a Finnex Ray II. I have also recently added a DIY CO2 system.
I am tired of my plants beautiful green being covered by this mystery brown sludge.

Is it a type of Algae or could it be caused by overfeeding the fish?

Any help is greatly appreciated.
Attached Thumbnails
Click image for larger version

Name:	IMAG0849_1.jpg
Views:	31
Size:	81.6 KB
ID:	247033  

Click image for larger version

Name:	IMAG0850_1.jpg
Views:	25
Size:	65.2 KB
ID:	247041  

Click image for larger version

Name:	IMAG0854_1.jpg
Views:	24
Size:	68.6 KB
ID:	247057  

Click image for larger version

Name:	IMAG0855_1.jpg
Views:	29
Size:	82.5 KB
ID:	247065  

Click image for larger version

Name:	IMAG0857_1.jpg
Views:	25
Size:	80.2 KB
ID:	247073  

erinbirdsong is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-16-2013, 07:20 PM Thread Starter
Algae Grower
 
PTrader: (4/100%)
Join Date: Nov 2013
Location: Colorado
Posts: 94
77 Views but no response? No one else has battled this or knows what it could be?
erinbirdsong is offline  
post #3 of 5 (permalink) Old 12-16-2013, 07:24 PM
Algae Grower
 
Entomologist210's Avatar
 
PTrader: (0/0%)
Join Date: Nov 2013
Location: Bryan, Texas
Posts: 79
I'm new to the hobby, but it looks like brown algae and dead bacteria, forming a brownish slime that covers your plants and rocks. I have this stuff in my tank, which has been running since October, but it's almost gone now.
Entomologist210 is offline  
 
post #4 of 5 (permalink) Old 12-16-2013, 07:30 PM
Planted Tank Obsessed
 
cbachmann's Avatar
 
PTrader: (6/100%)
Join Date: Aug 2013
Location: New York
Posts: 436
It sort of looks like BBA. One of the standard antialgae treatments is to spot treat with excel or hydrogen peroxide. Have you tried that? Also, how many fish do you have/how often and how much do you feed em? This is important information to help determine the kind of algae youve got.

My tanks:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cbachmann is offline  
post #5 of 5 (permalink) Old 12-16-2013, 11:51 PM Thread Starter
Algae Grower
 
PTrader: (4/100%)
Join Date: Nov 2013
Location: Colorado
Posts: 94
Quote:
Originally Posted by cbachmann View Post
It sort of looks like BBA. One of the standard antialgae treatments is to spot treat with excel or hydrogen peroxide. Have you tried that? Also, how many fish do you have/how often and how much do you feed em? This is important information to help determine the kind of algae youve got.
Thanks for the response.

I have not done any treating of the algae or funk because I wanted to figure out what it is first.

Here is the stock list:
6 Cories
11 Neon Tetras
1 Oto
1 Pleco
2 GBR's
2 Long Skirt Tetra's
1 Skunk Loach

As far as feeding goes I typically put a pinch of flakes in daily and 4-6 Veggie Wafers.
erinbirdsong is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome