I think a PH problem..Please help - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-04-2007, 12:33 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Jul 2007
Posts: 20
I think a PH problem..Please help

20G heavy planted tank, 2.25 WPG, C0-2 injection 20bpm on a timer
ammonia-0
Nitrite-0
nitrate-0
KH-1
ph-6
Fert-Plant Guild Green

Ok, so everything is looking great in my tank, Plants are are growing like crazy. Fish seems happy. No Algae problems at all.
This is my problem I can not keep shrimp to save my life. I cant seem to get a grip on what I am doing wrong. I think its my PH, but I cant figure out why.

Thanks in advance
okia42 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-04-2007, 12:36 AM
Planted Tank Obsessed
 
PTrader: (28/100%)
Join Date: Jul 2005
Location: Ohio
Posts: 429
What kind of shrimp?
Do you feed them? If so what?
You do not does nitrates?
Co2 will affect shrimp before fish I believe. Ofcourse 20bpm should be a problem.
riverrat is offline  
post #3 of 7 (permalink) Old 08-04-2007, 12:51 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Jul 2007
Posts: 20
Amano, Ghost, and CRS.
I do not feed. I have no time they die within a few days.
okia42 is offline  
 
post #4 of 7 (permalink) Old 08-04-2007, 12:53 AM
Planted Tank Obsessed
 
PTrader: (28/100%)
Join Date: Jul 2005
Location: Ohio
Posts: 429
Do you try to slowly acclimate them or just dump them in?
Maybe you should make a post in the shrimp threads. Might get more people into shrimp reading your post.

oop...i see you have
riverrat is offline  
post #5 of 7 (permalink) Old 08-04-2007, 12:56 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Jul 2007
Posts: 20
yes I put them in slow. and yes I am asking over there also.
Thanks
okia42 is offline  
post #6 of 7 (permalink) Old 08-04-2007, 05:29 AM
Planted Member
 
Ukrainetz's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2007
Location: Norwalk, CT
Posts: 280
Could be a calcium defficency... I guess the pH could also play a role in ruining their "shell".
Ukrainetz is offline  
post #7 of 7 (permalink) Old 08-04-2007, 08:16 AM
Planted Tank Guru
 
tazcrash69's Avatar
 
PTrader: (22/100%)
Join Date: Sep 2005
Location: Hawthorne, NJ
Posts: 3,207
Have you dosed any medicine that contains copper? Or something like snail-rid? Or has copper ever been used in the tank even before you had shrimp?

Walter

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or my
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Proud former member of:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


--May the floor under your tank always be dry, and your glass clear!!!
tazcrash69 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome