calcium deficiency at 14Gh? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-09-2007, 10:39 PM Thread Starter
Algae Grower
 
PTrader: (2/100%)
Join Date: Nov 2006
Location: the OC
Posts: 56
calcium deficiency at 14Gh?

This might be a dumb question but is calcium deficiency possible at 14Gh? I ask this because I'm seeing the symptoms as described in
http://www.csd.net/~cgadd/aqua/art_plant_nutrient.htm

Distorted leaf growth
cupped leaves
twisted and bent leaves
twisted and short roots
Damage and die off of growing points


thanks
john


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
istareatplants is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-09-2007, 11:27 PM
Are these real?
 
Wasserpest's Avatar
 
PTrader: (195/100%)
Join Date: Jun 2003
Location: Monterey, CA
Posts: 15,635
No dumb questions...

GH is mainly Ca and Mg, and if they are out of what at such high levels you can see deficiency symptoms. There are discussions where overage of one nutrient can hinder uptake of the other. If you can find out the levels of Ca and Mg in your water you might find some causes.

Do you see these problems with all plants? Some plants just don't like to grow in hard water, and rather than trying to fix things for them, a good solution might be to rip them out and replace them with hardier ones.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Wasserpest is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome