Trouble with Hydor 25 Watt heater. - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-07-2013, 04:03 AM Thread Starter
Planted Member
 
MDubbs's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2013
Location: New England
Posts: 226
Trouble with Hydor 25 Watt heater.

I bought this heater a little more than a month ago to heat up my 2.5 gallon, but now it's been moved to my 6.6 bookshelf tank that houses my Betta and four Ghost Shrimp.

It's set at 79 degrees, but I found out when I got home this evening that the water temperature was 84 degrees and the light was still on.

So, I lower the temp to shut it off. I then turn it back up to 79 and right now the light is back on and my tank's temp is at 82.2

The thermometer and heater are at opposite ends of the tank.

Has anyone used this heater and have trouble with it? I don't want to leave it on all night, but I'm afraid with the weather getting colder at night, I'll wake up to a dead fish in the AM.
MDubbs is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-07-2013, 07:58 PM
Planted Member
 
PTrader: (5/100%)
Join Date: Nov 2010
Location: Portland, Me.
Posts: 255
Is it a Theo? I had one do that, but only after I'd used it for about 5 years.
Sluggo is offline  
post #3 of 5 (permalink) Old 09-07-2013, 08:03 PM
Planted Tank Guru
 
acitydweller's Avatar
 
PTrader: (177/100%)
Join Date: Dec 2011
Location: New York
Posts: 7,691
i have 4 theos and found them to be the most reliable. i just threw away two Elite 25 w heaters, one of which overheated and killed two of my bettas.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"I am Groot", the faithful protector
acitydweller is offline  
 
post #4 of 5 (permalink) Old 09-08-2013, 01:42 AM
Planted Member
 
aquabruce's Avatar
 
PTrader: (2/100%)
Join Date: May 2012
Location: Milford, MA
Posts: 250
I'm starting to wonder about Hydor's reliability lately.

I bought an inline heater that didn't work at all, straight out of the box.

I bought it 3 months ago for a new tank I finally set up last week. The place I purchased it from only has a 60 day return policy so I had to contact Hydor.

It has a 2 year factory warranty but Hydor won't reimburse shipping so it cost me another $16.00 to ship it to Cali.

The said they will repair or replace it and ship it back to me.
aquabruce is offline  
post #5 of 5 (permalink) Old 09-08-2013, 02:56 AM Thread Starter
Planted Member
 
MDubbs's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2013
Location: New England
Posts: 226
I do believe it's a Theo.
MDubbs is offline  
Reply

Tags
help me please, hydor heater, newbie questions, suggestions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome