Algae Growth - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-16-2013, 08:56 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: Aug 2013
Location: United States
Posts: 1
Algae Growth

Hey All! New to forum, with some questions on my existing tank (set up for 9 months now).

It is heavily planted and heavily stocked. Everyone is healthy, but I am (of course) having a bit of an algae issue, and hoping you can help. Of course, I have a little green algae I clean off the glass weekly (no big deal) but my Anubias and Brazillian Pennywort have brown algae growing on the leaves. I'm not sure what steps to take to alleviate the problem. I am not dosing anything, and am feeding the fish every other day. 30-40% water changes every week or so.

The Tank:
37 Gallon (22" tall) makes lighting a challenge
Eheim 2217 Canister filter
Eheim 150W heater (keep tank at 78 degrees)
Light is a custom fixture using 4 - 13Watt CFL's 6500K (might be a little low - best I could do on a budget) - run about 10 hours a day.

The Livestock:
2 Angelfish (young and mid-sized)
2 Redline Torpedo Barbs (young)
6 Glowlight Tetras
5 Harlequin Rasboras
5 Cory Cats
6 small Mystery Snails

The Vegetation:
Anubias
Brazillian Pennywort
Ancharis
Vallisneria Spiralis
Dwarf Lilies
excalibur5 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome