Should I clean out the media in my Eheim 2217? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-18-2013, 03:53 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Apr 2013
Location: Ontario
Posts: 175
Should I clean out the media in my Eheim 2217?

I have an Eheim 2217 that will be hooked up to a heavily planted tank. Everything still works great on in except it hasn't been run in a tank in a year, should I clean out the media? Thanks !
sacme is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-18-2013, 04:12 PM
Surrounded by Blyxa
 
TexasCichlid's Avatar
 
PTrader: (27/100%)
Join Date: Jul 2011
Location: Texas
Posts: 1,518
Yes. Good time to lubricate seals too.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TexasCichlid is offline  
post #3 of 11 (permalink) Old 07-18-2013, 05:04 PM
Planted Tank Enthusiast
 
PTrader: (11/100%)
Join Date: Mar 2013
Location: Baltimore, Maryland
Posts: 529
+1 for lubricating the seals.

I started up a Fluval 205 after over a year of dormancy, and not to my surprise, it leaked! Turns out after a year of sitting, the rubber seals needed to be replaced. I recommend lubricating them and running the filter under supervision for a while in case it leaks.

Josh
---
75g | 22g Long
Cyanider is offline  
 
post #4 of 11 (permalink) Old 07-18-2013, 05:29 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Apr 2013
Location: Ontario
Posts: 175
Sorry I'm not the most knowledgeable when it comes to filters. Is there any special way to do this or should I just open it up and lubricate them? Any kind of lubrication you suggest?
sacme is offline  
post #5 of 11 (permalink) Old 07-18-2013, 05:37 PM
Planted Tank Enthusiast
 
PTrader: (11/100%)
Join Date: Mar 2013
Location: Baltimore, Maryland
Posts: 529
Just the seals on the filter assemble (where the two pieces connect, you'll se a rubber black ring).

People typically use vaseline.

Josh
---
75g | 22g Long
Cyanider is offline  
post #6 of 11 (permalink) Old 07-18-2013, 05:50 PM
Algae Grower
 
PTrader: (3/100%)
Join Date: Oct 2012
Location: Sacramento
Posts: 26
While vaseline works, it along with other petroleum based products will damage most orings over time and eventually cause them to crack. If you want longevity, find a silicon based grease. You can even get food grade if you are paranoid about your fish.

Last edited by Rudger; 07-18-2013 at 05:51 PM. Reason: grease, not any lube.
Rudger is offline  
post #7 of 11 (permalink) Old 07-18-2013, 10:10 PM
Planted Tank Guru
 
Jeff5614's Avatar
 
PTrader: (52/100%)
Join Date: Dec 2005
Location: TN
Posts: 3,604
Quote:
Originally Posted by Rudger View Post
While vaseline works, it along with other petroleum based products will damage most orings over time and eventually cause them to crack. If you want longevity, find a silicon based grease. You can even get food grade if you are paranoid about your fish.
Although, Vaseline is the lubricant that Eheim recommends. Maybe they know something we don't.
Jeff5614 is offline  
post #8 of 11 (permalink) Old 07-19-2013, 12:03 AM
Algae Grower
 
PTrader: (3/100%)
Join Date: Oct 2012
Location: Sacramento
Posts: 26
I they say to use it, I guess it is fine. Maybe they use a petroleum safe oring.
Rudger is offline  
post #9 of 11 (permalink) Old 07-19-2013, 12:42 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2013
Location: Pa
Posts: 32
Eheim will be glad to sell you new seals after they swell and get soft from using Vaseline.
In the plumbing section of any Lowes or Home Depot you should be able to find plumbers silicone.

Carl
Carlc1 is offline  
post #10 of 11 (permalink) Old 07-19-2013, 01:08 AM
Planted Tank Guru
 
mott's Avatar
 
PTrader: (32/100%)
Join Date: Nov 2006
Location: nj
Posts: 2,101
I've used Vaseline for about 8 years now, no visible signs of swelling or getting soft as you say, no problems what so ever.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

EHEIM Pimp Club Member #250 2217,2026,2236
mott is offline  
post #11 of 11 (permalink) Old 07-19-2013, 02:09 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Apr 2013
Location: Ontario
Posts: 175
Thanks for the help everyone, I'm doing it today!
sacme is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome