New Freshwater Tank Setup Help - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-29-2013, 10:00 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: May 2013
Location: Tennessee
Posts: 1
Cool New Freshwater Tank Setup Help

I recently cleaned out a 29 gal. aquarium that hasn't been in use for probably a couple of years now. I'm trying to set up a new community tank. Yesterday I put the sand and water into the tank. I used CaribSea Arag-Alive Live Reef Sand. It seems as if the sand has still not settled completely because the tank is still very cloudy (24 hours later). Is this a normal occurrence?

I haven't run my filter yet because I'm afraid whatever sediment is still floating around could ruin the filter. I read somewhere not to run the filter until all the sediment is settled. Does this seem like a good idea?

I also added around 3mL of Seachem Prime to prep the water to be cycled in the near future. I added some live plants today as well. Anything recommendations other than achieving proper temperature and chemical levels before adding a cycling fish?
-Thanks
JMCWDE is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-29-2013, 10:47 PM
Planted Tank Enthusiast
 
Black Hills Tj's Avatar
 
PTrader: (2/100%)
Join Date: Jul 2008
Location: Rapid City, South Dakota
Posts: 762
Some sand can take longer than others to settle. Running your filter shouldnt hurt and will speed up the process.

Id personally suggest reading up on the fishless cycle if you havent already.
Black Hills Tj is offline  
post #3 of 4 (permalink) Old 05-30-2013, 02:42 AM
Wannabe Guru
 
Kitsune_Gem's Avatar
 
PTrader: (0/0%)
Join Date: Apr 2012
Location: San Ramon, Ca
Posts: 1,041
Send a message via Skype™ to Kitsune_Gem
Quote:
Originally Posted by JMCWDE View Post
CaribSea Arag-Alive Live Reef Sand.
You do know this type of sand is prepped for SALT water tanks, not fresh?

Also please do not cycle your tank out with fish.

"And 5, very important 5... Don't let me eat pears.. I HATE PEARS."
Kitsune_Gem is offline  
 
post #4 of 4 (permalink) Old 05-30-2013, 03:17 AM
Newbie
 
thelub's Avatar
 
PTrader: (15/100%)
Join Date: Jan 2013
Location: SE Washington
Posts: 1,983
Quote:
Originally Posted by Kitsune_Gem View Post
You do know this type of sand is prepped for SALT water tanks, not fresh?

Also please do not cycle your tank out with fish.
I had to re-read your post. I thought you said without fish.

That sand may spike your PH. Its used in SW tanks where the PH needs to be much higher than a freshwater tank.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
thelub is offline  
Reply

Tags
freshwater aquarium, freshwater plants, sand, setup

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome