So Upsetting - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-13-2013, 03:08 AM Thread Starter
Planted Tank Enthusiast
 
hunterlook's Avatar
 
PTrader: (2/100%)
Join Date: Feb 2013
Location: Denver, CO
Posts: 515
So Upsetting

So I finally got my hands on a 40B and cleaned/filled it yesterday. Came with substrate and all that jazz so the water tested perfect for a fully cycled tank. It came with a crappy emperor 400 so I decided to go out and buy a Fluval AC 110 and versa top for it and when I got home, this happened....





Sorry for the crappy photos (took with my phone). I was upset but not livid until I called PetSmart and found out that I had purchased the last one and my local Petco didn't have any in. Now I'm forced to wait over a week for their shipment, I'm considering just ordering one online at this point and getting next day shipping.

Sorry for the rant, It's just a tad irritating.

The versa top is great though!
hunterlook is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-13-2013, 03:10 AM
AVN
Wannabe Guru
 
AVN's Avatar
 
PTrader: (18/100%)
Join Date: Oct 2012
Location: SoCal
Posts: 1,141
Just wait. Who needs a filter anyways? No harm will befall anything in a 40B without a filter for a week.

hi
AVN is offline  
post #3 of 6 (permalink) Old 03-13-2013, 03:23 AM
Planted Tank Guru
 
DarkCobra's Avatar
 
PTrader: (5/100%)
Join Date: Jun 2004
Location: Baton Rouge, LA
Posts: 3,350
RIP Aquaclear 110. That's a shame.

What was the problem with the Emperor?
DarkCobra is offline  
 
post #4 of 6 (permalink) Old 03-13-2013, 03:40 AM Thread Starter
Planted Tank Enthusiast
 
hunterlook's Avatar
 
PTrader: (2/100%)
Join Date: Feb 2013
Location: Denver, CO
Posts: 515
Quote:
Originally Posted by DarkCobra View Post
RIP Aquaclear 110. That's a shame.

What was the problem with the Emperor?
The motor and impeller are on the way out, I cleaned the whole thing with vinegar and even soaked it and theres still water flow issues. It can barely turn the bio wheels at this point and sometimes isn't strong enough to even push water over the outflows
hunterlook is offline  
post #5 of 6 (permalink) Old 03-13-2013, 04:13 AM
Planted Tank Guru
 
DarkCobra's Avatar
 
PTrader: (5/100%)
Join Date: Jun 2004
Location: Baton Rouge, LA
Posts: 3,350
Dang. First the tank, then the filter, now ANOTHER filter.

Let's hope this is a case of "trouble comes in threes", and this is the end of it!
DarkCobra is offline  
post #6 of 6 (permalink) Old 03-13-2013, 04:15 AM Thread Starter
Planted Tank Enthusiast
 
hunterlook's Avatar
 
PTrader: (2/100%)
Join Date: Feb 2013
Location: Denver, CO
Posts: 515
Quote:
Originally Posted by DarkCobra View Post
Dang. First the tank, then the filter, now ANOTHER filter.

Let's hope this is a case of "trouble comes in threes", and this is the end of it!
Ugh, I hope so. My Finnex fixture gets in Thursday so I'm praying thats not shattered. I'm pretty sure getting the light will be what really gets the ball rolling on this.
hunterlook is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome