New Additions to My Tank - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-23-2013, 06:31 AM Thread Starter
Planted Tank Enthusiast
 
hunterlook's Avatar
 
PTrader: (2/100%)
Join Date: Feb 2013
Location: Denver, CO
Posts: 515
New Additions to My Tank

Well today was pay day and my LFS conveniently got a massive plant shipment in so I made a pit stop on my way home from work

I only had a sword, anubias, madagascar lace and anacharis. Today I picked up:
-2 Marble Queen Swords
-1 Amazon Sword
-2 more bunches of Anacharis
-1 Java Fern
-3 Narrow Leaf Chain Sword
-3 other mixtures of different grasses
-1 Banana Plant

I rearranged my tank and am extremely happy with how it turned out! Next on my list is some Flame Moss for my driftwood and Java Moss for the empty foreground you see.

I'm not sure what type of sword is in the front right of my tank but it seems to be growing a black algae on it, any idea what it could be and how to treat it?

Also, random shot I got of my massive Ghost shrimp with half of another Ghost inside of him! Freaky stuff...



hunterlook is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome