Planted 55 need help - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-02-2005, 04:37 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Nov 2005
Posts: 4
Planted 55 need help

I have flourite substrate additives mixed with natural gravel im diffusing co2 running 2 powerheads a corallife 96watt planted tank fixture with new bulbs i belive they're like 5k. I've had the 55gallon up with plants in it for around 6 months or so and am battling algae. My ph is around 7.4 and the general hardness is around 10 I have hair algae strands almost a foot long if i neglect it long enough. I have Rotala sp. Java Fern some nana anubius. The Rotala sp. grow incredibly fast. I have been dosing some iron which im guessing is responsible for the hair algae so I have discontinued using it. I have some BGA slime it's almost completely gone now and I havent changed a thing. My java moss grows very slow along with my Vallisneria americana and the nana. The root systems are getting huge but the above substrate plants are not showing alot of growth. Should I be measuring nitrates and dosing? What fish are recomended to eat most of the algae that will be ok with glow light tetras and rummynose tetras. Once I get this under controll I'm hoping to add more hard to keep plants so any help will be apriciated thanks
slinky is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-02-2005, 12:30 PM
Planted Tank Guru
 
Rex Grigg's Avatar
 
PTrader: (65/100%)
Join Date: Dec 2002
Location: Portland Orygun
Posts: 9,600
Take a few minutes and read my Guide.

Pay very close attention to the area of Nutrients.

Sounds like the plants are starving and the algae is thriving.
Rex Grigg is offline  
post #3 of 4 (permalink) Old 11-03-2005, 05:20 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Nov 2005
Posts: 4
I read it and bought some fetilizers i just dosed it's some stuff they import from the uk my lfs had a planted tank and all he used was this it contains all of the nutrients described in your write up just dosed up and bought a bunch of cherry shrimp and some riccia and pulled my bio wheel filters. I'm using tap instead of ro right now. i know that it has some effect on algae but im guesing you said it's ok because the plants will out compete the algae for the nutrients if im missing something let me know. Thanks for the great info.
slinky is offline  
 
post #4 of 4 (permalink) Old 11-03-2005, 12:27 PM
Planted Tank Guru
 
Rex Grigg's Avatar
 
PTrader: (65/100%)
Join Date: Dec 2002
Location: Portland Orygun
Posts: 9,600
There is no reason to use RO water.

I doubt that the fertilizer you bought will raise your tank to the levels needed. There is NOT one complete fertilizer on the market that does that.
Rex Grigg is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome