IceCap 660 buzzed and then stopped lighting - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-31-2005, 04:02 AM Thread Starter
Planted Tank Obsessed
 
Silent Running's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2004
Location: Seattle
Posts: 482
IceCap 660 buzzed and then stopped lighting

I have an IceCap 660 running 4 48" GE Daylight Ultra bulbs. It was working flawlessly for nearly a year until the other night. At one point, it made a buzzing noise and then the lights went out. I checked the fuse, it was blown. So I replaced it. It immediately blew the new fuse. I swapped out all of the bulbs for new ones and re-seated all of the wire connections at the end caps to make sure they were in good order. I also re-seated the wiring harness connector at the ballast. I also put another new fuse in. When I plugged it in, there was a slight popping sound, no light and another blown fuse. Do I need to send the ballast in for service, or is there something else I can check? Thanks!

Paul

"I'd like to think oysters transcend national barriers." - Roger Waters

Eheim Pimp Club Member #64

My old 100 Gallon SeaClear established 11/7/2004. 4 GE Daylight Ultras on IceCap VHO ballasts. 3" Eco-complete substrate. Eheim 2028, pressurized CO2, external reactor. 18 watt Turbo Twist UV.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Silent Running is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-01-2005, 05:28 PM Thread Starter
Planted Tank Obsessed
 
Silent Running's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2004
Location: Seattle
Posts: 482
IceCap is having me send in the ballast. I'll update the thread with what they have to say...

Paul

"I'd like to think oysters transcend national barriers." - Roger Waters

Eheim Pimp Club Member #64

My old 100 Gallon SeaClear established 11/7/2004. 4 GE Daylight Ultras on IceCap VHO ballasts. 3" Eco-complete substrate. Eheim 2028, pressurized CO2, external reactor. 18 watt Turbo Twist UV.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Silent Running is offline  
post #3 of 6 (permalink) Old 09-01-2005, 05:40 PM
Wannabe Guru
 
BlueRam's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2004
Location: Seattle, WA
Posts: 1,666
I can chip in a 4X 4' ballast (retail ~$18) if you need something to light NO bulbs for a while...

Moved to Tucson.
BlueRam is offline  
 
post #4 of 6 (permalink) Old 09-02-2005, 01:37 AM Thread Starter
Planted Tank Obsessed
 
Silent Running's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2004
Location: Seattle
Posts: 482
Hey thanks for the offer, I appreciate it! I've already got it covered though with some spare NO bulbs and ballasts I had. Thanks, though!

Paul

Paul

"I'd like to think oysters transcend national barriers." - Roger Waters

Eheim Pimp Club Member #64

My old 100 Gallon SeaClear established 11/7/2004. 4 GE Daylight Ultras on IceCap VHO ballasts. 3" Eco-complete substrate. Eheim 2028, pressurized CO2, external reactor. 18 watt Turbo Twist UV.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Silent Running is offline  
post #5 of 6 (permalink) Old 09-02-2005, 11:18 PM
Planted Tank Obsessed
 
zapus's Avatar
 
PTrader: (1/100%)
Join Date: May 2004
Location: Athens, Georgia
Posts: 328
Sounds like you've already got it covered, but for future reference, Icecap has their own forum over at ReefCentral. Their tech guys monitor it regularly, answering a steady stream of questions.

Well, at least my algae is pearling...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zapus is offline  
post #6 of 6 (permalink) Old 09-02-2005, 11:45 PM Thread Starter
Planted Tank Obsessed
 
Silent Running's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2004
Location: Seattle
Posts: 482
Thanks, yeah, that's where I posted it.

Paul

"I'd like to think oysters transcend national barriers." - Roger Waters

Eheim Pimp Club Member #64

My old 100 Gallon SeaClear established 11/7/2004. 4 GE Daylight Ultras on IceCap VHO ballasts. 3" Eco-complete substrate. Eheim 2028, pressurized CO2, external reactor. 18 watt Turbo Twist UV.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Silent Running is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome