Just got eco-complete - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-07-2005, 12:18 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Feb 2005
Posts: 36
Just got eco-complete

I just began my new nano-cube 6g with Eco Complete. Unfortunately, it's been about 2 hours, and the water is still a thick hazy milky white.

anyone know how to determine if my eco-complete was part of the bad batch? and when should i expect the milky water to clear up?
Avi S is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-07-2005, 12:20 AM
Planted Tank Guru
 
PTrader: (86/100%)
Join Date: Mar 2004
Location: Michigan
Posts: 2,670
You probably have a bad batch, but again it takes up to 24hours until mine cleared up. Wait until tommorow and see what happens.
Jdinh04 is offline  
post #3 of 11 (permalink) Old 07-07-2005, 12:43 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Feb 2005
Posts: 36
thanks man - i hope i dont have a bad batch.

what happens/happened with the bad batch of eco-complete?
Avi S is offline  
 
post #4 of 11 (permalink) Old 07-07-2005, 01:05 AM
Planted Tank Guru
 
PTrader: (86/100%)
Join Date: Mar 2004
Location: Michigan
Posts: 2,670
Quote:
Originally Posted by Avi S
thanks man - i hope i dont have a bad batch.

what happens/happened with the bad batch of eco-complete?
Usually you get a brand new one for free, but I don't know how that is possible.
Jdinh04 is offline  
post #5 of 11 (permalink) Old 07-07-2005, 02:00 AM
Planted Tank Enthusiast
 
turbomkt's Avatar
 
PTrader: (3/100%)
Join Date: Jun 2004
Location: San Diego, Ca
Posts: 506
Send a message via AIM to turbomkt Send a message via MSN to turbomkt Send a message via Yahoo to turbomkt
If you've got a bad batch, Carib Sea was replacing them for free. I got a bad batch but didn't realize it until the whole bag was in my 10g. A couple of water changes later and the milkiness was gone. It doesn't screw up water chemistry much, if at all. Maybe just a tad harder than normal.

--Mike
Eheim Pimp #41

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
turbomkt is offline  
post #6 of 11 (permalink) Old 07-07-2005, 04:13 AM
Wannabe Guru
 
lumpyfunk's Avatar
 
PTrader: (32/100%)
Join Date: Dec 2004
Location: Prior Lake, MN (Twin Cities)
Posts: 1,602
Test for phospate if you have really high levels send an email to [email protected] and tell them about it, they most likely will send you a new bag of eco. Very nice to see a company stand behind their product like this, kudos for them!!!
lumpyfunk is offline  
post #7 of 11 (permalink) Old 07-07-2005, 11:33 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Feb 2005
Posts: 36
okay, I will do that - thank you all for your help. I'll test for phosphates tonight after work.
Avi S is offline  
post #8 of 11 (permalink) Old 07-08-2005, 11:42 AM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Feb 2005
Posts: 36
Well, the cloudy water has become clear. After 24-36 hours, it cleared up. : )

I really like the eco-complete. Very easy to keep rooted plants down.
Avi S is offline  
post #9 of 11 (permalink) Old 07-08-2005, 02:55 PM
Planted Tank Guru
 
PTrader: (86/100%)
Join Date: Mar 2004
Location: Michigan
Posts: 2,670
See told you, patience can save you a lot of money. Good luck with the tank, hope to see it soon.
Jdinh04 is offline  
post #10 of 11 (permalink) Old 07-08-2005, 03:13 PM
Planted Tank Obsessed
 
Cheeseybacon's Avatar
 
PTrader: (0/0%)
Join Date: Feb 2005
Location: Chambersburg, PA
Posts: 495
Send a message via AIM to Cheeseybacon Send a message via Yahoo to Cheeseybacon
I'd still get another bag if I were you. I have a corrupted batch in my 10-gallon right now, and I really wish I had replaced it. No matter how crystal clear the water may be right now, the white crud always comes back to haunt me everytime I plant or disturb the substrate.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cheeseybacon is offline  
post #11 of 11 (permalink) Old 07-08-2005, 10:26 PM Thread Starter
Guest
 
PTrader: (0/0%)
Join Date: Feb 2005
Posts: 36
i'm not going to get another bag - this one is fine. pics in this thread : https://www.plantedtank.net/forums/sh...ad.php?t=19053
Avi S is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome