Plant troubles, need help - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-15-2012, 01:53 AM Thread Starter
Planted Tank Enthusiast
 
PTrader: (11/100%)
Join Date: Sep 2011
Location: FL
Posts: 580
Plant troubles, need help

I recently bought two larger crypt plants, not sure exactly which kind, but they have broad leaves atop long stems approx 12 inches tall. They have only been in my tank a week now, and one leaf on each plant is yellowing and starting to deteriorate away. What could be causing this? Any thoughts? Side note, for the most part all of the rest of my plants seem to be doing well. Except my ludwigia repens which the bottom leaves keep falling off either bc a fish is picking them off or i dont know. Please help. Thanks
falcooo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-15-2012, 02:00 AM
Wannabe Guru
 
Daximus's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2011
Location: Kansas
Posts: 1,877
Some Crypts will do this sometimes when they are replanted in water with different conditions. As long as the rest of your plants are cool I'd guess your new crypts will come around soon enough.
Daximus is offline  
post #3 of 3 (permalink) Old 03-15-2012, 02:05 AM Thread Starter
Planted Tank Enthusiast
 
PTrader: (11/100%)
Join Date: Sep 2011
Location: FL
Posts: 580
Cool, thats what i was hoping to hear. Thanks.
falcooo is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome