Tiny white organisms in substrate? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-29-2011, 05:16 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2011
Location: Calgary, Canada
Posts: 40
Tiny white organisms in substrate?

Hi,

My planted tank is three weeks old with a few snails that magically appeared, along with six Cherry Red Shrimp. I can't remember the name of the substrate but it starts with 'Aqua' (not AquaSoil). It was touted as ready for a planted tank with no washing required. It contained water already. It's a fairly new product on the market and the few reviews I read here (after the fact) weren't that positive. Thus far though, I haven't noticed anything wrong with it.

Now that the details are out of the way, I'm seeing these tiny, pin-prick, white organisms in the substrate. Some move onto the glass and others onto the driftwood. They move extremely fast when in the open water. When on the glass, I've seen two types. One looks like spermatoza with a head and tail while the other looks like it has a couple of antennae or arms sticking out.

Are these baby snails? There must be hundreds in the substrate but I'm not seeing an increase in the snail population so most must not live long.

Just trying to figure out what's going on in my tank... It doesn't seem like they do any harm.

Thanks.
jslmsca is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-29-2011, 05:42 PM
Wannabe Guru
 
PTrader: (8/100%)
Join Date: Feb 2008
Location: Washington, DC
Posts: 1,062
https://www.plantedtank.net/forums/sh...nize-them.html

Which of the bugs from the above link do they look like?
redfalconf35 is offline  
post #3 of 4 (permalink) Old 07-29-2011, 08:19 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2011
Location: Calgary, Canada
Posts: 40
Thank you for the link. I didn't realize 'bugs' were a natural part of the aquarium. It looks like I have a combination of Copepods/Seed Shrimp. I may have Tubifex too but mine are not as red.

Good to know...
jslmsca is offline  
 
post #4 of 4 (permalink) Old 07-29-2011, 08:21 PM
Wannabe Guru
 
PTrader: (8/100%)
Join Date: Feb 2008
Location: Washington, DC
Posts: 1,062
good live food for your fish!
redfalconf35 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome