Dead Sword? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-22-2011, 05:10 AM Thread Starter
JxL
Algae Grower
 
JxL's Avatar
 
PTrader: (9/100%)
Join Date: Jun 2011
Location: NJ
Posts: 128
Dead Sword?

I have 3 very small swords that I got and they appear to be dieing or dead. They arrived like this when they got to my house. Are they goners or should I just leave them in th tank to see if they recover. I couldnt get a good picture because of where they are placed, but I circled the leaves of the visible sword. The other swords' leaves look the same and most of the leaves on the plant are brown like this or have fallen off. Here is the picture. What do you think?

JxL is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-22-2011, 05:40 AM
Planted Member
 
jdm68's Avatar
 
PTrader: (1/100%)
Join Date: Jun 2011
Location: NE Minneapolis, MN
Posts: 220
Where did you get them from?

When I got mine, they had been grown emersed, so when they went into the tank I got some major yellowing of the leaves and they had some holes develop, but within a week or two they sprouted new leaves from the middle of the plant. I then just snipped off the dying leaves and they've been good since. This was in extremely low light as well. Hopefully yours recover. Good luck.
jdm68 is offline  
post #3 of 6 (permalink) Old 07-22-2011, 05:44 AM Thread Starter
JxL
Algae Grower
 
JxL's Avatar
 
PTrader: (9/100%)
Join Date: Jun 2011
Location: NJ
Posts: 128
THey were grown emersed. So should I just leave them in?
JxL is offline  
 
post #4 of 6 (permalink) Old 07-22-2011, 06:22 AM
Planted Member
 
jdm68's Avatar
 
PTrader: (1/100%)
Join Date: Jun 2011
Location: NE Minneapolis, MN
Posts: 220
Well I guess that depends on how long you've been waiting on them. If it's been a couple days, I'd say definitely leave them in. If they've been planted for 2 weeks or a month, or their condition is just getting worse, then I'd say take them out. Mind you, I am no expert, but that's my view from what I've experienced with this plant.
jdm68 is offline  
post #5 of 6 (permalink) Old 07-22-2011, 02:09 PM
Algae Grower
 
PTrader: (1/100%)
Join Date: May 2011
Location: Canada
Posts: 56
Mine did the same at first now it had a bunch of very long new leaves that sprouted since I planted it. As mentioned above the melting is due to the plant being first grown emersed.
nameless? is offline  
post #6 of 6 (permalink) Old 07-22-2011, 02:41 PM Thread Starter
JxL
Algae Grower
 
JxL's Avatar
 
PTrader: (9/100%)
Join Date: Jun 2011
Location: NJ
Posts: 128
Ok I will leave them in the tank. Should I cut ALL of the brown leaves off?
Thanks!
JxL
JxL is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome