DHG Belem wont grow:( - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-19-2011, 06:01 PM Thread Starter
Algae Grower
 
PTrader: (2/100%)
Join Date: Aug 2006
Location: Jersey City, NJ
Posts: 145
DHG Belem wont grow:(

I dont know what else to do. My DHG belem is growing so slowly it is now beginning to get covered with brown algae AGAIN.

I have a 14G biocube, 36W T5, CO2 at 3bubble/sec (dropchecker near yellow), eco complete substrate, and dose 1ML of seachem potassium + 1ML of tripica plant nutrient+ daily.

Why wont my DHG grow? I am almost tempted just to pull everything out and replace it with dwarf sag again. arggg

Here's the nutrient list of tropica plant nutrient+. What am i missing? what's out of balance?

N 1.34%
P 0.10%
K 1.03%
Mg 0,39%
S 0.91%
B 0.004%
Cu 0.006%
Fe 0.07%
Mn 0.04%
Mo 0.002%
Zn 0.002%.
HEEDTA
DTPA
E123


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gagaliya is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-19-2011, 10:47 PM
Planted Member
 
PTrader: (1/100%)
Join Date: Mar 2010
Location: Ft Leavenworth KS
Posts: 217
Belem always takes a long time in my tanks to kick start dont worry im sure it will start growing soon

how long has it been in there?
doubleott05 is offline  
post #3 of 7 (permalink) Old 07-19-2011, 11:00 PM
Wannabe Guru
 
IWANNAGOFAST's Avatar
 
PTrader: (33/100%)
Join Date: Jan 2008
Location: San Francisco
Posts: 1,905
Mine took forever to get going, but once it does it fills in quick, well, quick-ish.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
IWANNAGOFAST is offline  
 
post #4 of 7 (permalink) Old 07-20-2011, 09:12 AM Thread Starter
Algae Grower
 
PTrader: (2/100%)
Join Date: Aug 2006
Location: Jersey City, NJ
Posts: 145
it's been about 40 days.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gagaliya is offline  
post #5 of 7 (permalink) Old 07-20-2011, 02:54 PM
Planted Tank Obsessed
 
JRMott's Avatar
 
PTrader: (2/100%)
Join Date: Jul 2010
Location: NYC
Posts: 426
I had some DHG (i don't know if it was Belem) in my tank last year, it never took off for me either. I've since rebooted my tank and am trying Micro Sword "Narrow Leaf" (Lilaeopsis Mauritiana) this time around. I'm trying to be more diligent about the tank this time, in hopes of getting a nice foreground going.

I don't know much about the ferts you're using, but I think you're missing out on some micros. From what I understand, macros and micros can't be dosed together, so it seems you're missing something.

I'm using rootmedic's liquid ferts (though it seems most people here prefer dry due to their lower cost). A 500ml bottle of Justin's micro formula should last you around 1.5 years based on 3-4 doses per week: http://rootmedic.net/products-page/l...ents/micro-500

I'd also consider adding some root tabs to the belem and seeing if that helps at all. These are the ones I've added: http://rootmedic.net/products-page/d.../1-rm-complete

From what I've been hearing, it just takes a while for these plants to get going. 2+ months is not uncommon.

Hang in there.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JRMott is offline  
post #6 of 7 (permalink) Old 07-20-2011, 03:12 PM
Algae Grower
 
PTrader: (3/100%)
Join Date: Dec 2007
Location: Plano, Tx
Posts: 142
I'm growing my Belem Emersed so its a bit different then you, but I'm at 8 weeks and its just now starting to send out lots of runners. I imagine in a few more weeks it will start spreading fast.
madhatter4 is offline  
post #7 of 7 (permalink) Old 07-21-2011, 01:16 AM Thread Starter
Algae Grower
 
PTrader: (2/100%)
Join Date: Aug 2006
Location: Jersey City, NJ
Posts: 145
it's tough though, because if they dont grow fast then algae does I made the mistake of not having some faster grower in there with DHG, didnt realize slow they grow.

I guess i will let nature make the decision if the DHG can out compete the brown algae let it be, if they all get covered with brown algae i will just pull all of it out and let dwarf sags have their day.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gagaliya is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome