Help Ammonia won't go away! No Nitrites or Nitrates! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-04-2020, 04:05 AM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: Mar 2013
Location: Long Island NY
Posts: 3
Hey everyone,

So I have a new 20 gallon tank that cycled nearly a month ago. That was the last time I saw a nitrite reading. Since then 0 nitrites. I last had a reading on nitrates back on 3/19/20. Since then 0s.

At that time I added 2 kribensis, but I took them out after a week ( they were trying to eat everything and everyone) and added 10 Cardinal tetras instead.

I am overstocked. I know how terrible this is, but I really love all these fish. I'm ok with additional pwc's, but why is my tank not processing ammonia? I am stumped. I would expect there to be some nitrates, but still none. Everyone seems happy and healthy, but I can't understand why I have ammonia, 0 nitrites and 0 nitrates. Please help me understand this.

20 gallon tank,
penguin 250 biowheel hob filter w/ matrix biomedia added 4 days ago, air pump for added Oxygen
Planted tank with eco-complete.
Planted with 2 x Java fern, 2 x narrow leaf java, 3 x h compacta siamensis, 1 x Amazon sword, 1 x large Asian fern, multiple small African water fern and 1 x moss ball, a couple spots of dwarf hairgrass, but they aren't doing great. Plenty of drift wood.
Weekly suplimitation of excel, iron and flourish. Flourish tabs also in substrate.

8 x longfin zebra danios
10 x small Cardinal tetras
4 x emerald Cory cats
2 x gold inca mystery snails
3 x cherry shrimp

Any insight into what's going on would be a huge help. Thank in advance everyone!

Quote:
Originally Posted by ricklax96 View Post
Hey everyone,

So I have a new 20 gallon tank that cycled nearly a month ago. That was the last time I saw a nitrite reading. Since then 0 nitrites. I last had a reading on nitrates back on 3/19/20. Since then 0s.

At that time I added 2 kribensis, but I took them out after a week ( they were trying to eat everything and everyone) and added 10 Cardinal tetras instead.

I am overstocked. I know how terrible this is, but I really love all these fish. I'm ok with additional pwc's, but why is my tank not processing ammonia? I am stumped. I would expect there to be some nitrates, but still none. Everyone seems happy and healthy, but I can't understand why I have ammonia, 0 nitrites and 0 nitrates. Please help me understand this.

20 gallon tank,
penguin 250 biowheel hob filter w/ matrix biomedia added 4 days ago, air pump for added Oxygen
Planted tank with eco-complete.
Planted with 2 x Java fern, 2 x narrow leaf java, 3 x h compacta siamensis, 1 x Amazon sword, 1 x large Asian fern, multiple small African water fern and 1 x moss ball, a couple spots of dwarf hairgrass, but they aren't doing great. Plenty of drift wood.
Weekly suplimitation of excel, iron and flourish. Flourish tabs also in substrate.

8 x longfin zebra danios
10 x small Cardinal tetras
4 x emerald Cory cats
2 x gold inca mystery snails
3 x cherry shrimp

Any insight into what's going on would be a huge help. Thank in advance everyone!
Also:
Temp: 75f
pH 6.4
Ammonia .5-1ppm
Nitrite 0
Nitrate 0
Alk 40ppm
GH 60 ppm

Last edited by Darkblade48; 04-04-2020 at 08:16 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
ricklax96 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-04-2020, 04:36 AM
Planted Member
 
PTrader: (0/0%)
Join Date: Jul 2017
Posts: 174
Obviously you added fish too soon thatís one problem, coulda probably added a few but you overstocked.
How much water are you changing out, water changes are a good thing in your situation but might be the reason your not seeing a rise in nitrates. If you are changing out a lot of water it might just take it longer to cycle.


Sent from my iPhone using Tapatalk
Matt69 is offline  
post #3 of 3 (permalink) Old 04-04-2020, 05:30 AM
Planted Tank Guru
 
DaveKS's Avatar
 
PTrader: (0/0%)
Join Date: Apr 2019
Location: 67212
Posts: 2,106
Did you continue adding ammonia in between time you got to end of cycling and when you 1st got fish? How long was that period?

You basically have to give bacteria a ammonia source dosing or ghost feeding to keep them fed until you add livestock, then fish waste will take over.

But yea you way overstocked to quickly. Should have done the 8 danio and stopped there for next month or so.

Good thing is your PH is low enough that most of your ammonia is in the form of ammonium which is way less lethal than ammonia. Keep it down there. If your change water has a higher PH (6.8-7) be careful, you can cause a ammonia spike if your water change raises PH above 6.8.

Go get some true floating plants like frogbit, dwarf water lettuce or red root floaters and cover about 1/3-1/2 water surface. They are high metabolism/uptake plants because they get all the light and CO2 they want at surface. They can really suck down some ammonium and nitrates in a hurry. Donít let someone talk you into hornwort, anachris as a floater, not the same, get a true floating plant. And avoid duckweed at all costs, once you get that in your tank itís a plague of biblical proportions.

Red root floaters, leaves out of water sucking up light and CO2.


Roots sucking up nutrients from water. Very pretty and effective plant.

Last edited by DaveKS; 04-04-2020 at 05:41 AM. Reason: Content
DaveKS is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome