Stumped - Need help on Planted Tank - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-30-2019, 10:15 PM Thread Starter
Algae Grower
 
Druinz's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2019
Posts: 8
Stumped - Need help on Planted Tank

Hello, I've set up a 29g planted tank, and plants are just doing horribly?! I've no clue why. I feel I've done everything right but clearly there's something I missed. Here's some information and pictures.

Lights: 2 10w "t5" LED Tubes, 6000k
CO2: Pressurized co2 with an atomizer
Fertilizers: I EI dose with macros on MWF, Micros (CSM+B) on T/TH/SA, with a 50% WC on Sundays. I've also put root tabs under every area that there are plants.
Substrate: EcoComplete (40lb total)

Livestock: very light, only 6 ember tetras and 2 pygmy cories (I know, I'll be getting more soon.)

Almost all my Staurogyne repens have died/melted away, and my other plants are HARDLY growing if at all, which I feel should be growing insanely fast considering this should be a hi-tech tank?


I've also got a nuisance brown filamentous/slime algae? It's been driving me absolutely nuts. I've tried added a lot of flow, very low flow, lowering light, raising light, increasing co2, decreasing co2, raising ferts, lowering ferts, nothing seems to help

Anyway there's obviously something I'm doing wrong, I just don't know what. Please help!
Attached Thumbnails
Click image for larger version

Name:	JPEG_20190308_142303.jpg
Views:	2
Size:	144.3 KB
ID:	879739  

Click image for larger version

Name:	IMG_20190330_180406.jpg
Views:	2
Size:	174.6 KB
ID:	879741  

Click image for larger version

Name:	IMG_20190316_164418.jpg
Views:	2
Size:	197.4 KB
ID:	879743  

Druinz is offline  
Reply

Tags
brown algae, melting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Multiple Tank Builds] Hello... It's Been 10+ Years Since My Last Login turtlehead Tank Journals 139 12-01-2018 02:38 AM
Beginner high-tech low-maintenance 75g tank (new to this) newtothis Tank Journals 6 08-24-2015 01:46 PM
Forum Rules - Updated December 17, 2010 KyleT Important Update/Announcements 13 07-18-2014 05:04 AM
New Planted Tank - Challenges So Far... blue_waters Low Tech Forum 4 01-21-2014 02:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome