CO2 won't flow when restarting solenoid - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-22-2019, 03:13 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2015
Posts: 11
CO2 won't flow when restarting solenoid

As the title states I'm having issues where my CO2 won't begin flowing after I restart my solenoid from the timer. It's as if the tubing is getting back flow and can't restart unless I turn up the CO2 really high at which point the tube flies off the diffuser. What am I doing wrong or am I missing a component of my system?

I'm using the following items.

https://www.amazon.com/Premium-AQUAT.../dp/B009WTXYN0

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
samue202 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-22-2019, 03:29 PM
Planted Tank Guru
 
Nlewis's Avatar
 
PTrader: (3/100%)
Join Date: Dec 2015
Location: Northern Va
Posts: 2,398
Do you have a check valve installed on your co2 tubing?

Just a noob


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nlewis is online now  
post #3 of 6 (permalink) Old 03-22-2019, 05:20 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2015
Posts: 11
Quote:
Originally Posted by Nlewis View Post
Do you have a check valve installed on your co2 tubing?
I do not.
samue202 is offline  
 
post #4 of 6 (permalink) Old 03-22-2019, 06:19 PM
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Jan 2018
Posts: 447
How long did you let it sit? It's not like turning on a light switch. I don't have that exact one but one very similar. Depending on how much tubing, working pressure, etc., may take a little while before it builds enough pressure to start to flow. If it flows when you crank it up, then that shows that the solenoid is open and it's flowing and kind of demonstrates the point. Let it run for ~30 min or so and it probably will start bubbling.

Also without a check valve water may siphon back into the tube and it will have to push that out first.

Also need to check for leaks. Some may not appear until there's enough pressure in the system.
Mike A. is offline  
post #5 of 6 (permalink) Old 03-22-2019, 07:37 PM
Wannabe Guru
 
PTrader: (6/100%)
Join Date: Jan 2014
Location: United States
Posts: 1,659
You could have a clogged diffuser. Try removing the diffuser. Turn on the solenoid and see if CO2 flows through the open tube.

Once you get it squared away I would advise you to get a check valve installed. It's cheap and you don't want water in your regulator!
Kubla is online now  
post #6 of 6 (permalink) Old 03-23-2019, 03:48 PM
Planted Tank Guru
 
Nlewis's Avatar
 
PTrader: (3/100%)
Join Date: Dec 2015
Location: Northern Va
Posts: 2,398
Quote:
Originally Posted by samue202 View Post
I do not.


You absolutely need a check valve installed on your co2 tubing. This may solve your issue as water may be making its way into the tubing and when the system turns on it will take awhile for it to push the water back out.


Sent from my iPhone using Tapatalk

Just a noob


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nlewis is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Solenoid and flow meter for CO2 System Liquidgarden Equipment 1 10-26-2018 07:33 PM
DIY Co2 Regulator how-to INFO (lot of pics) smoq DIY 11 05-10-2016 06:48 AM
Flaws in Kh chart regarding CO2 content Hardstuff General Planted Tank Discussion 29 09-20-2014 07:08 PM
no CO2 flow after solenoid opens 9am53 Equipment 4 03-19-2010 11:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome