Does this look normal? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-18-2019, 07:07 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2019
Posts: 15
Does this look normal?

I have 2 mysteries one gold and one black. My gold one acts like speed racer running laps around his tank lol but my black on is kinda sluggish and doesnt move around alot. Does his shell look ok. Thinking maybe hes not feeling well maybe. Anyone have any suggestions?


Sent from my iPhone using Tapatalk
DavesTanks is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-18-2019, 08:41 PM
Planted Tank Guru
 
AquaAurora's Avatar
 
PTrader: (36/100%)
Join Date: Jul 2013
Location: south eastern PA
Posts: 5,571
Black one seems to have a calcium deficiency in its shell. Was it bought from a different seller (or not at the same time as the yellow?). Some calcium rich snail food (i think people recommend snello) will help. There are other options for adding calcium to the aquarium but some may effect parameters which might upset otehr fish/inverts (if you have shrimp).

Due to photobuckets new bs cost for use of images on forums I have deleted all photobucket accounts. I apologize if you enjoyed or found my photos helpful.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AquaAurora is offline  
post #3 of 3 (permalink) Old 03-19-2019, 03:12 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2019
Posts: 15
Thats what im thinking. I bought them at the same time from the new petsmart. I added some cuttle bone but i may have to get some calcium


Sent from my iPhone using Tapatalk
DavesTanks is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
yellow electric blue jack dempsey, normal? shrimpNewbie Fish 5 08-13-2011 12:07 AM
Is this how a normal crypt wendtii brown looks? VeeSe Plants 4 05-23-2011 01:31 AM
Is this a normal level of new tank diatoms? VeeSe Algae 1 05-07-2011 06:37 AM
Is it normal to have this in a new tank? Golightly Algae 5 02-20-2011 09:04 PM
Normal KH drop? aquaman3000 General Planted Tank Discussion 2 10-26-2007 03:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome