New planted aquarium need help! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-29-2015, 12:00 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2015
Location: Baltimore
Posts: 15
New planted aquarium need help!

Hello all!
I recently moved and brought a 20 gallon fish tank with me to set up and I have some general and specific questions to ask.
I've had a few tanks in the past that include 55 gal cichlid and 29 gal community tank. I've tried live plants in the past but it never really worked out well.
So I've set up my new tank for about 4 weeks now. I've done my research this time now and from the beginning I've wanted a lush planted aquarium. To start I purchased fluval substrate, t8 power-glo bulb for my hood, Carib-sea gravel and have a penguin 200 hanging filter. I laid the substrate on the bottom and topped it with gravel because I don't care for the dirt look of straight substrate. I have a nice piece of drift wood now and bought a few plants to start the tank (attached you can see the plants I started out with) with 5 white cloud minnows and Cory for fish to start. I also made a diy co2 generator out of a 2 liter bottle and Gatorade bottle. That has been running for about a week now and I can see the growth already. Everything looks to be doing well I just have some questions about some new observations.
-Was fluval substrate a good choice? It was the best kind they had at my local store.
-what level of light will this t8 super-glo give me? I have a hood on the tank and read somewhere that wrapping the part around the light with aluminum foil will help disperse the light, is that a good idea?
-I've noticed some small snails making their way around the tank is that a bad thing? I don't want them to harm my plants in the long run.
- once I started running the diy co2 generator my ph went from about 6.8 to around 6. My set up is a 2 liter leading into a 32 oz Gatorade bottle then thru a check valve and airstone into the tank. I saw bubbles after about 4 hours and it's going steady but due to the ph drop is it too much for a 20 gal and harmful to my fish? I use about a half packet of yeast and 2 cups of sugar.
-I see a weird type of slime growing on my drift wood (photo attached). It's not algae but more like a clear growth. Any idea what this is and if it's good or bad?
- plants wise I think it might be time to start to trim a bit and plant the tops so it gets a thicker plant look. I'm also planning on getting a few more different types of plants like a Amazon sword or 2, Java moss and maybe another kind of mid-size plant. Any ideas on some aquascaping that will give me a lush thick look?
- the types of fish I want to get are another Cory or 2, maybe a few more white cloud minnows or add some more colored fish. I want to eventuality get some angel fish to go with the plants and maybe blue fish (can't remember their name). I've read that angels need a bit of a larger tank but I would like to get a pair of smaller Angels and let them grow to the dive of the tank. Will 2 angles with 10-12 smaller schooling fish and a few corys work?
Thanks you everyone as you can see I have a good start but want to make sure I reach my goal. So far I really like where my tank is going and need some advice before I invest in any more fish/plants. And suggestions will help and thank you in advance!
Attached Images
File Type: jpg image.jpg (95.9 KB, 0 views)
Josher is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome