Regulator unchecked - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-07-2020, 06:39 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2020
Posts: 8
Regulator unchecked

Pro-SE Series worked great for a few weeks. Then had to clean out a bit of "dirt" that blocked the working pressure side. When I put it back together, the CO2 now comes through the regulator full blast. I can't titrate it down. Thoughts?
fergusonian is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-19-2020, 01:38 AM
Newbie
 
PTrader: (0/0%)
Join Date: Aug 2020
Posts: 1
I had similar problems when mine arrived and I set it up. I undid both stages and cleaned everything and it works fine now.
I had a faulty check valve in the bubble counter and for water in there, and probably some dirt.
Crazyhorse77 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome