RO Salts burning mont carlo? - The Planted Tank Forum
 3Likes
  • 1 Post By H'C
  • 1 Post By H'C
  • 1 Post By nanomania
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-05-2020, 04:37 PM Thread Starter
H'C
Newbie
 
PTrader: (0/0%)
Join Date: Nov 2020
Location: England
Posts: 2
RO Salts burning mont carlo?

hello guys. So i did a 90% water change and instead of mixing the salts in a bucket to remineralise the ro water, i added them straight into the aquarium because i was being lazy. Anyway i noticed later that my some of mont carlo carpet some of the leaves were burned.
fairly certain its not a defeciency as its not the whole carpet just some leaves towards the front where i added the salts.
so can remineralising salts burn plant leaves if the land on them?
nanomania likes this.
H'C is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-05-2020, 05:30 PM
Planted Member
 
nanomania's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2011
Location: india
Posts: 287
Quote:
Originally Posted by H'C View Post
hello guys. So i did a 90% water change and instead of mixing the salts in a bucket to remineralise the ro water, i added them straight into the aquarium because i was being lazy. Anyway i noticed later that my some of mont carlo carpet some of the leaves were burned.

fairly certain its not a defeciency as its not the whole carpet just some leaves towards the front where i added the salts.

so can remineralising salts burn plant leaves if the land on them?
I am facing same issue using seachem equilibrium, even though i premix before adding. Planning to stop it.

Sent from my POCO F1 using Tapatalk
nanomania is offline  
post #3 of 4 (permalink) Old 11-09-2020, 09:02 AM Thread Starter
H'C
Newbie
 
PTrader: (0/0%)
Join Date: Nov 2020
Location: England
Posts: 2
yep thats one reason i have not used equilibrium. i heard a few times it burns plants leaves if added straight in.
i guess its back to mixing them in a bucket for me then . its strange you know because lots of people seem add their salts straight into the aquarium?
nanomania likes this.
H'C is offline  
 
post #4 of 4 (permalink) Old 11-09-2020, 09:18 AM
Planted Member
 
nanomania's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2011
Location: india
Posts: 287
Quote:
Originally Posted by H'C View Post
yep thats one reason i have not used equilibrium. i heard a few times it burns plants leaves if added straight in.
i guess its back to mixing them in a bucket for me then . its strange you know because lots of people seem add their salts straight into the aquarium?
Mine burnt even after premixing half the dose recommend. Im using tap water gh 3, kh 2. Im keeping up with weekly 60% wc, and adding tropica double the recommend dose. Things are getting better.

Sent from my POCO F1 using Tapatalk
H'C likes this.
nanomania is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome