Rotala rotundifolia (ceylon) sickly leaves - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-14-2020, 04:40 PM Thread Starter
Algae Grower
 
Pareeeee's Avatar
 
PTrader: (0/0%)
Join Date: May 2005
Location: Ontario, Canada
Posts: 18
You guys helped me out so much with my last question (thanks again) that I am hoping you can help me with this one!

My Rotala rotundifolia finally took off in the last 30 days or so, since I put in the Osmocote root tabs. It's been spreading everywhere, even during my algae bloom. I got rid of the bloom and now all of a sudden the Rotala leaves have this translucent mottled look to them. At first I thought it was algae growing on them but upon further inspection it does not appear to be that. Also seeing leaves floating around on the surface now. Pics attached!

I use Flourish liquid plant supplement for micro ferts and Osmocote root tabs for macros. I also use co2 (bubble counter). Lighting: two 6500k T8 LED bulbs in a converted fluorescent fixture (33Gal/125L) = 22.4 Watts/Litre.

Forgot to post the pic
Attached Thumbnails
Click image for larger version

Name:	20201014_110237_1602690108887.jpg
Views:	12
Size:	5.86 MB
ID:	904135  


Pareeeee ><((((>

Last edited by Darkblade48; 10-14-2020 at 08:43 PM. Reason: Please use the edit function for back to back posts to keep threads cleaner
Pareeeee is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-20-2020, 09:53 PM Thread Starter
Algae Grower
 
Pareeeee's Avatar
 
PTrader: (0/0%)
Join Date: May 2005
Location: Ontario, Canada
Posts: 18
Six days and no responses??

Thankfully I found my answer elsewhere.

Pareeeee ><((((>
Pareeeee is offline  
post #3 of 3 (permalink) Old 10-22-2020, 09:48 PM
Planted Member
 
PTrader: (0/0%)
Join Date: Aug 2012
Location: Ann Arbor, MI USA
Posts: 291
Where? I just returned after 8 years and the community seems less robust than it used to be. Any suggestions?
Sotty is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome