What is happening to my Frogbit? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-09-2020, 05:58 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2020
Posts: 7
What is happening to my Frogbit?

I got this frogbit about 10 days ago. I've lost about 8 leaves so far, they all turn brown with this pattern on them so I trim them off. I can see this starting on about 5 leaves right now.


It's in a 10 gallon tank with some neon tetras, an oto, and a few cherry shrimp. I have a Nicrew light that says 11 watts/ 640 lumens. I am using a preset heater and the tank is consistently 82 degrees, which i know is a bit high. I'm currently using Seachem Flourish but someone recommended Easy green so I will be getting that next week. I have no lid on the tank to prevent condensation and I turned my filter way down so there's no current in this half of the tank. Any ideas?
Attached Thumbnails
Click image for larger version

Name:	20201008_192443_1602219508361.jpg
Views:	10
Size:	215.6 KB
ID:	903923  

rachaellee is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-09-2020, 07:15 AM
Algae Grower
 
hyperheide's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2020
Location: Berlin, Germany
Posts: 14
A lack of potassium would be my best guess.

Please excuse my spelling and grammar mistakes... English is not my native language.
Here are some videos that I made with nice underwater-footage of my fishies:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hyperheide is offline  
post #3 of 3 (permalink) Old 10-09-2020, 05:49 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2020
Posts: 7
Quote:
Originally Posted by hyperheide View Post
A lack of potassium would be my best guess.
Hopefully the easy-green will help, thank you!
rachaellee is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome