Staurogyne Repens rapid die off. - The Planted Tank Forum
 2Likes
  • 2 Post By cl3537
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-09-2019, 06:08 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: May 2019
Posts: 2
Staurogyne Repens rapid die off.

I'm new to the forum and this is my first post. I have a 29 gallon and I'm also running CO2. My S. repens has been doing well and is established. Was planted form tissue culture about 5 months ago. I noticed a dead patch in the center of my carpet and I just cut it out. Now that patch is spreading quickly from the center. Any insight will be helpful. I attached a link to pics, I think.
https://imgur.com/a/RLWnOr6
TeknoTim is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-09-2019, 06:30 PM
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Jan 2019
Location: Montreal, Quebec
Posts: 387
Welcome to TPT.

For better advice it would be helpful to provide all details of your tank to get the best diagnosis possible. I see several unhealthy plants in that picture not just S. Repens.

A Full Tank Shot, your CO2 levels(ideally pH at lights on and off), Your Weekly fertilizer dosing in ppm of all Macros and your Micro Dosing.
frogmanjared and Greggz like this.
cl3537 is offline  
post #3 of 3 (permalink) Old 05-09-2019, 06:59 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: May 2019
Posts: 2
Thanks. I will update with all that info.
TeknoTim is offline  
Reply

Tags
die, repens

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Staurogyne repens looks wrong adairjenkins Plants 5 03-01-2015 12:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome