Substrate - Page 3 - The Planted Tank Forum
Threads in Forum : Substrate Forum Tools Search this Forum
  Thread / Thread Starter Last Post Reverse Sort Order Replies Views
 
Sticky Thread Sticky: Substrate Articles and FAQ

07-23-2012 03:39 PM
by Wasserpest Last Post
0 45,705
 
 

03-21-2019 06:59 PM
by toothless assasin Last Post
0 135
 

03-20-2019 09:57 PM
by gus6464 Last Post
2 400
 

03-19-2019 10:41 PM
by xjasminex Last Post
4 344
 

03-18-2019 07:08 PM
by shaonrahman Last Post
2 378
 

03-18-2019 07:02 PM
by shaonrahman Last Post
1 231
 
ADA Amazonia STILL clouding water (Multi-page thread 1 2)

03-18-2019 05:46 PM
by sweeneycam Last Post
23 891
 

03-18-2019 04:11 PM
by Cyano Last Post
4 239
 

03-18-2019 01:42 PM
by Cinnamonamon Last Post
2 158
 

03-18-2019 01:04 AM
by Foley588 Last Post
0 180
 

03-17-2019 01:15 AM
by stephen.scott Last Post
0 122
 

03-15-2019 06:09 PM
by Hayad2002 Last Post
3 224
 

03-15-2019 04:38 PM
by micheljq Last Post
7 318
 

03-15-2019 06:02 AM
by Mattypants Last Post
1 218
 

03-15-2019 04:20 AM
by NunsOnRipple Last Post
0 69
 
acidic rock, substrate Acidic Rocks? (Multi-page thread 1 2)

03-12-2019 04:28 AM
by MassiveDynamic17 Last Post
23 909
 

03-10-2019 09:19 AM
by ben6229 Last Post
0 150
 

03-09-2019 12:12 PM
by somewhatshocked Last Post
20 1,628
 

03-09-2019 07:49 AM
by Mike A. Last Post
8 468
 

03-07-2019 02:19 AM
by MSaxen Last Post
2 276
 

03-06-2019 11:05 PM
by aubie98 Last Post
0 128
Post New Thread

Display Options
Showing threads 41 to 60 of 7969
 
Forum Tools Search this Forum
Mark This Forum Read
View Parent Forum
Search this Forum :

Advanced Search

New posts New posts More than 15 replies or 150 views Hot thread with new posts
No new posts No new posts No new posts Hot thread with no new posts
Closed Thread Thread is closed  

 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome