eco complete - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-09-2012, 10:49 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2012
Location: Connecticut
Posts: 59
eco complete

I have bags of eco complete but do I need to break down my tank to install it?

Also, do I really need to wash out the liquid its packaged in?

Any tips on the use of this stuff?
sir kyle is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-09-2012, 11:48 PM
Planted Tank Obsessed
 
Gooberfish's Avatar
 
PTrader: (1/100%)
Join Date: Mar 2012
Location: San Francisco
Posts: 330
Send a message via AIM to Gooberfish
I didn't wash out the liquid. Just poured it straight in the tank.

What do you mean "break down the tank." Are you doing a substrate change?
Gooberfish is offline  
post #3 of 7 (permalink) Old 06-10-2012, 12:38 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2012
Location: Connecticut
Posts: 59
not a substrate change, a new install
sir kyle is offline  
 
post #4 of 7 (permalink) Old 06-10-2012, 01:23 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2010
Location: SF Bay Area, CA
Posts: 64
Just dump it in if theres no fish/plants.
krillkill is offline  
post #5 of 7 (permalink) Old 06-10-2012, 02:48 AM
Planted Tank Guru
 
acitydweller's Avatar
 
PTrader: (177/100%)
Join Date: Dec 2011
Location: New York
Posts: 7,695
its ready for use out of the bag.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"I am Groot", the faithful protector
acitydweller is offline  
post #6 of 7 (permalink) Old 06-10-2012, 03:00 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2012
Location: Connecticut
Posts: 59
Sorry, I should have said this tank has been established for a few years now and it does have tropical fish in it. It is cycled and I have some live plants ATM. I will replant them when I redo the substrate. I need to purchase some rocks and DW.
sir kyle is offline  
post #7 of 7 (permalink) Old 06-12-2012, 11:38 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2012
Location: Australia
Posts: 6
just top off your current layer
amphiprion is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome