I'm really torn as to what to do.. - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-15-2011, 05:09 PM Thread Starter
Planted Tank Obsessed
 
Akira's Avatar
 
PTrader: (0/0%)
Join Date: May 2008
Location: Mobile, Alabama
Posts: 326
Send a message via AIM to Akira
I'm really torn as to what to do..

Okay so I've made serveral posts about my situation and I just can't figure out what to do. I had a 20 gallon full of amazonia that I basically neglected and the water evaporated completely about a year ago. Fast forward I put that substrate in my fluva flora and the water has been cloudy in it and te few trash plants i put in it have developed white hair algea. Could the algea be coming from the substrate itself?

Should I soak the amazonia in peroxide/rinse(i dunno how) and let it dry out and try that or should I buy some substrate from the LFS and go with that??

I really dont want to lose all that amazonia if I dont have to..

Eheim Pimp #292

Akira is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-15-2011, 06:08 PM
Planted Tank Enthusiast
 
vespers_'s Avatar
 
PTrader: (0/0%)
Join Date: May 2011
Location: Canada
Posts: 618
i doubt it is the substrate. when it gets wet it will simply suck up some water. it is also natural for the water to be cloudy after you just fill it up. as for the algae, no clue, but i don't think it is from the substrate.

75G Paludarium Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


filstar pimp #171
vespers_ is offline  
post #3 of 8 (permalink) Old 05-15-2011, 06:46 PM
Planted Tank Obsessed
 
PTrader: (12/100%)
Join Date: Oct 2009
Location: Lees Summit, MO
Posts: 434
just give your tank time to settle down and see if the algae goes away...if it gets worse turn down lights, turn up co2 and see if that helps


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GROW BABY GROW
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
Baadboy11 is offline  
 
post #4 of 8 (permalink) Old 05-15-2011, 07:16 PM Thread Starter
Planted Tank Obsessed
 
Akira's Avatar
 
PTrader: (0/0%)
Join Date: May 2008
Location: Mobile, Alabama
Posts: 326
Send a message via AIM to Akira
I've given it a few days to settle while doing some wc's...i got some cheap plants from pet smart so the algea might've come with them..im just at a loss :-/

but tonight ill get my DIY co2 going and inject the tank.

Eheim Pimp #292

Akira is offline  
post #5 of 8 (permalink) Old 05-15-2011, 11:28 PM
Fresh Fish Freak
 
lauraleellbp's Avatar
 
PTrader: (70/100%)
Join Date: Feb 2008
Location: Tampa, Florida
Posts: 24,403
Have you checked your ammonia levels?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Next meeting Monday, Oct 13, 2014 @ 7:15pm- See ya there!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lauraleellbp is offline  
post #6 of 8 (permalink) Old 05-15-2011, 11:55 PM Thread Starter
Planted Tank Obsessed
 
Akira's Avatar
 
PTrader: (0/0%)
Join Date: May 2008
Location: Mobile, Alabama
Posts: 326
Send a message via AIM to Akira
No i havent but ive done massive massive water changes..and when i first cycled this stuff*amazonia is known for its ammonia spikes* i never ran into this

Eheim Pimp #292

Akira is offline  
post #7 of 8 (permalink) Old 05-16-2011, 01:29 AM
Planted Tank Guru
 
PTrader: (84/100%)
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 21,012
The Amazonia aquasoil should be thoroughly mineralized from the first use and long drying out time. I think it is as good as new now. As far as algae goes, most algae are the result of too much light. What is the tank size, dimensions, and what lighting are you using?

Hoppy
Hoppy is offline  
post #8 of 8 (permalink) Old 05-16-2011, 01:30 AM Thread Starter
Planted Tank Obsessed
 
Akira's Avatar
 
PTrader: (0/0%)
Join Date: May 2008
Location: Mobile, Alabama
Posts: 326
Send a message via AIM to Akira
I put it in a fluval flora..so..7 gallons 13 watts..

Eheim Pimp #292

Akira is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome