We are at war soldier, with sulfur bubbles.... - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-06-2010, 04:19 AM Thread Starter
Wannabe Guru
 
pianofish's Avatar
 
PTrader: (26/100%)
Join Date: Jan 2010
Location: Lafayette, Louisiana
Posts: 1,051
We are at war soldier, with sulfur bubbles....

Hey everyone,
I am using a substrate of 1/2- 3/4 inch of MTS with a Flourite cap. Well today I was catching a sick fish, and as I was doing so I uprooted a plant, I planted it back and I felt the substrate and there was a lump in it so I pressed down and a big bubble spirted out. I sniffed it and low and behold.... Rotten Eggs. My fish seem okay when they come out, but it can't be good for them right? I pressed around a little more and there were alot of bubbles. What can I do?

Thanks,

Piano
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pianofish is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-06-2010, 01:27 PM
Fresh Fish Freak
 
lauraleellbp's Avatar
 
PTrader: (70/100%)
Join Date: Feb 2008
Location: Tampa, Florida
Posts: 24,403
You can poke holes throughout your substrate (a chopstick or something similar works well, and I'd do a big water change immediately afterwards) and get some Malasian trumpet snails.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Next meeting Monday, Oct 13, 2014 @ 7:15pm- See ya there!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lauraleellbp is offline  
post #3 of 3 (permalink) Old 04-07-2010, 07:44 PM Thread Starter
Wannabe Guru
 
pianofish's Avatar
 
PTrader: (26/100%)
Join Date: Jan 2010
Location: Lafayette, Louisiana
Posts: 1,051
Alright, did a little bit of replanting and poked lots of holes, (pressing down with your hand works well too) and just did a 35% water change.
Working on getting MTSnails.
Thanks for the help,

Piano
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pianofish is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome