Thrips! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-25-2016, 02:52 PM Thread Starter
Planted Member
 
PTrader: (5/100%)
Join Date: Mar 2009
Location: NYC
Posts: 223
Thrips!

Hi all,
My 150g riparium was doing really well, but I unfortunately got an infestation of thrips that has wiped out almost all my plants. Any thoughts on how to deal with these pests?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
the_deeb is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-26-2016, 03:32 AM
Planted Tank Guru
 
PTrader: (153/100%)
Join Date: Mar 2009
Location: Madison, Wisconsin
Posts: 9,750
Hi Adeeb. It's good to see you here.

Thrips are almost impossible to kill. If they have killed off or damaged many of the plants the easiest thing to do would be just pitch everything that is still left, carefully clean up and start over with new plants.

You could try a CO2 bomb for thrips, but that will probably only get the adults, not the eggs.
hydrophyte is offline  
post #3 of 4 (permalink) Old 05-03-2016, 07:46 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2007
Location: aurora, co
Posts: 18
Quote:
Originally Posted by the_deeb View Post
Hi all,
My 150g riparium was doing really well, but I unfortunately got an infestation of thrips that has wiped out almost all my plants. Any thoughts on how to deal with these pests?
I had to deal with thrips in a research lab. They were brutally difficult to control and the only solution was a product called Control SC. Not sure if they still make it but even it was not 100% effective. The main active ingredient if I recall is some extract from a fungus which is an insecticide so it's pretty benign to plants but I believe it may have also contained some amount of surfactant. Also I believe the product was incredibly expensive.
leesto is offline  
 
post #4 of 4 (permalink) Old 05-05-2016, 08:48 PM
Planted Tank Enthusiast
 
CannaBrain's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2008
Location: Arapahoe County, Colorado
Posts: 593
Out of curiosity, do you know if they were hitchhikers and if so, which plant they came in on?

Sent from my SPH-L710 using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CannaBrain is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome