Algae suffocating my plants? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-10-2021, 05:06 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2021
Posts: 6
Algae suffocating my plants?

I am not sure if this algae is hair/thread algae as its just short and furry not long and stringy. This algae is on every single leaf of every single plant in my tank and i have no idea what to do
I feel like because of this algae, my plants are slowly dying because they simply are too weak now and cannot out compete the algae on their leaves.

What do you do to get algae off of plants specifically? (Please dont say i have to take out my plants and dip them in something because i would cry if i had to replant the monte carlo carpet)
Omar23 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-10-2021, 05:14 AM
Planted Member
 
PTrader: (0/0%)
Join Date: Jul 2017
Posts: 194
It seems like your having a lot of issues all at once.
How long has your tank been set up and what kind of light do you have?
How long do you leave the light on?
What kind of substrate do you have?
Also give us all the water perimeters you can provide.


Sent from my iPhone using Tapatalk
Matt69 is online now  
post #3 of 4 (permalink) Old 01-10-2021, 05:36 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2021
Posts: 6
Lighting is nicrew g2 classic led 11w. I leave it on for 8 hours but recently started putting the timer for 4 hours on, 2 hours off, 4 hours on
Tank is 7 gallon cube been set up for about 4 months
Substrate is tropica soil powder with root tabs and i fertilize with thrive all in 1 liquid fertilizer (1 pump a week after 50% water change)
The parameters were all stable when i tested last but my test kit is expired now so i cant be sure of the numbers unfortunately
Water is always RO and remineralized with seachem equilibrium

Also a side note, i recently started using 0.5ml of flourish excel every day. The guy at the fish store suggested that i take all the fish out and heavily dose flourish excel every day for 2 weeks to get rid of this algae, not too sure if that is good advice

Bump: Btw is it possible to send images if im on mobile? It might be easier to see the thin green film over all the plants through a picture. Thanks for your response
Omar23 is offline  
 
post #4 of 4 (permalink) Old 01-10-2021, 06:10 AM
Planted Member
 
PTrader: (0/0%)
Join Date: Jul 2017
Posts: 194
I use Tapatalk so it makes it easy to attach a photo from a mobile device.

Cut your light to 6 hours a day or 3 on 2 off 3 on if you like the siesta.

Start feeding your fish half as much.

Start dosing 1ml of excell daily.

Floating plants might help your situation with algae and your frightened chili rasboras. You just need to get an airline hose and make a dam or loop so they donít get pulled into your filter.

I would do a 3 day black out before I pulled all the fish out and dosed heavy with excell.
Some people are against blackouts I think they work fine but my wife thinks itís cruel punishment to the fish so I donít do them anymore. If you do it do a big water change before and remove as much algae by hand as you can and a big water change when finished.

How many fish live in this 7 gallon tank?.


Sent from my iPhone using Tapatalk
Matt69 is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome